Bug 624105 - config.cgi missing custom field info
config.cgi missing custom field info
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.6
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-13 12:40 EDT by Charley Wang
Modified: 2013-06-23 21:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 01:28:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charley Wang 2010-08-13 12:40:12 EDT
Quick summary:

Please set blank string as an acceptable value for custom fields. (The custom fields I can see as not having a blank-string option are target_release and cust_facing.) 

Would it be possible to tune config.cgi to give valid options for each custom field? Giving this information appears to be the default behaviour for Bugzilla 3.6.


Description of problem:

Two problems, 2) is easier to fix:

1) The configuration file for Red Hat Bugzilla does not give possible options for custom fields. 

2) In the absence of this information, Mylyn will attempt to send a blank string as the option value for custom fields, but some custom fields do not accept a blank string as an option.

The two issues combined make it difficult to work with the installation, but just solving 2) would be a big help.

In XML format, an entry like this would be expected for cf_cust_facing:
  <bz:cf_cust_facing>
    <Seq>
        <li>---</li>
        <li>Yes</li>
        <li>No</li>
    </Seq>
  </bz:cf_cust_facing>

These entries appear to be automatically generated by config.cgi when a custom field is modified. 


How reproducible:
Always.


Steps to Reproduce:
1. Attempt to create a new bug on https://partner-bugzilla.redhat.com
2.
3.
  
Actual results:
Error: No customer facing specified


Expected results:
Create new bug.
Comment 1 David Lawrence 2010-08-13 14:10:38 EDT
Was this function in Bugzilla 3.4 and no longer in 3.6 or is this something you are asking to be added that wasn't there before?

Dave
Comment 2 Charley Wang 2010-08-13 15:20:15 EDT
The list of custom field options is not available on https://bugzilla.redhat.com either. Was it removed to reduce the size of the config.cgi downloads? 

My test Bugzilla server can't duplicate the situation perfectly, but it looks like setting blank strings as fields will not work. Unchecking 'Can be set on bug creation' in the property page of the custom fields looks like it does work. However, I don't know what conflicts this may create elsewhere. I do not see any options to set custom fields on the bug creation pages, but that doesn't mean the ability to set them on creation is not used.

It would be really nice if Bugzilla would give a list of possible options for
custom fields, or if that is not possible, then at least the subset of custom
fields that can be set on bug creation :)

I understand if this is not a concern leading up to your rebuild today, though.

Thanks for taking a look!
Comment 3 Charley Wang 2010-08-23 15:17:27 EDT
Hi,

I experimented a bit with a local Bugzilla installation, and I can reproduce what is happening by commenting out the following lines in config.cgi:

  $vars->{'custom_fields'} = 
  [ grep {$_->is_select} Bugzilla->active_custom_fields ];

This gets rid of the list of legal values in the configuration file. Could these lines be added back? By default they are in the same section as the other calls to get_legal_field_values in config.cgi.

Thanks!
-Charley
Comment 6 Jeff Fearn 2012-05-30 00:42:17 EDT
As part of the recent Bugzilla 2.4 upgrade the Bugzilla team are cleaning up bugs opened against old versions of Bugzilla. This bug has been flagged as an old bug and will be CLOSED WONTFIX in 7 days time.

If you believe this bug is an issue in the latest Bugzilla version please comment on this bug within 7 days. Doing so will ensure this bug is not closed automatically.

Thanks, the Bugzilla team.
Comment 7 Jeff Fearn 2012-07-19 01:28:49 EDT
As noted previously, the Bugzilla Team is cleaning up a large number of outstanding issues that have bit rotted. This bug is being closed as there has been no response to that notification.

If you believe this bug is still important please reopen this bug in the NEW status and PM will consider it.

Note You need to log in before you can comment on or make changes to this bug.