Bug 62414 - mount fails on boot when filesystem has label
mount fails on boot when filesystem has label
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
7.2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-31 08:39 EST by Ron Yorston
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 18:07:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ron Yorston 2002-03-31 08:39:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.9-31 i586)

Description of problem:
I'm seeing an intermittent failure to mount filesystems with labels.  The error
message is:

   mount: special device LABEL=/usr does not exist

Five boots out of ten have this problem.  alane@geeksrus.net has already pointed
out in bug 35980 that mount suffers from the same problem in reading
/proc/partitions that was causing strange behaviour in fsck.  If I apply
essentially the same fix to mount that alane supplies (in attachment 15406 [details]) for
fsck mount works properly in ten boots out of ten.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.  Use labelled filesystems in /etc/fstab.
2.  Have sufficient filesystems that /proc/partitions is > 1024 bytes.
3.  Boot the system.
	

Actual Results:  Five times out of ten mounting of labelled filesystems failed
at the 'Mounting local filesystems' phase.  The filesystems are mounted at a
later phase, but not before various other things have gone wrong.  e.g.
/usr/sbin/kudzu couldn't be run because /usr wasn't mounted.

Expected Results:  All filesystems should have been mounted without complaint.

Additional info:
Comment 1 Elliot Lee 2002-04-15 12:04:33 EDT
mount_by_label.c in rawhide now uses a 16k buffer, which should aleviate a
significant number of these problems.

Note You need to log in before you can comment on or make changes to this bug.