Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 624140 - Once you get a pulp consumer cli error any consumer cli commands ends up with the same error
Once you get a pulp consumer cli error any consumer cli commands ends up with...
Status: CLOSED DUPLICATE of bug 624083
Product: Pulp
Classification: Retired
Component: z_other (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Preethi Thomas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-13 15:15 EDT by Preethi Thomas
Modified: 2011-07-15 15:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-17 11:01:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2010-08-13 15:15:43 EDT
Description of problem:


If you get a consumer cli error once, all the other consumer cli commands you enter ends up with the same error message.



[root@preethi pulp]# pulp-client -u admin -p admin consumer create --id=rlx-3-24.rhndev.redhat.com --description=test-consumer1 --server=preethi.usersys.redhat.com
Traceback (most recent call last):
  File "/usr/bin/pulp-client", line 100, in <module>
    PulpRegister().main()
  File "/usr/lib/python2.6/site-packages/pulptools/pulpcli.py", line 108, in main
    cmd.main()
  File "/usr/lib/python2.6/site-packages/pulptools/core/basecore.py", line 115, in main
    self._do_core()
  File "/usr/lib/python2.6/site-packages/pulptools/core/core_consumer.py", line 112, in _do_core
    self._create()
  File "/usr/lib/python2.6/site-packages/pulptools/core/core_consumer.py", line 135, in _create
    consumer = self.cconn.create(self.options.id, self.options.description)
  File "/usr/lib/python2.6/site-packages/pulptools/connection.py", line 265, in create
    return self.conn.request_put(method, params=consumerdata)
  File "/usr/lib/python2.6/site-packages/pulptools/connection.py", line 108, in request_put
    return self._request("PUT", method, params)
  File "/usr/lib/python2.6/site-packages/pulptools/connection.py", line 83, in _request
    headers=self.headers)
  File "/usr/lib64/python2.6/httplib.py", line 898, in request
    self._send_request(method, url, body, headers)
  File "/usr/lib64/python2.6/httplib.py", line 935, in _send_request
    self.endheaders()
  File "/usr/lib64/python2.6/httplib.py", line 892, in endheaders
    self._send_output()
  File "/usr/lib64/python2.6/httplib.py", line 764, in _send_output
    self.send(msg)
  File "/usr/lib64/python2.6/httplib.py", line 723, in send
    self.connect()
  File "/usr/lib64/python2.6/site-packages/M2Crypto/httpslib.py", line 50, in connect
    self.sock.connect((self.host, self.port))
  File "/usr/lib64/python2.6/site-packages/M2Crypto/SSL/Connection.py", line 184, in connect
    if not check(self.get_peer_cert(), self.addr[0]):
  File "/usr/lib64/python2.6/site-packages/M2Crypto/SSL/Checker.py", line 123, in __call__
    fieldName='commonName')
M2Crypto.SSL.Checker.WrongHost: Peer certificate commonName does not match host, expected preethi.usersys.redhat.com, got localhost
[root@preethi pulp]# 
[root@preethi pulp]# 
[root@preethi pulp]# 
[root@preethi pulp]# 
[root@preethi pulp]# pulp-client -u admin -p admin consumer create --id=rlx-3-24.rhndev.redhat.com --description=test-consumer1 
Traceback (most recent call last):
  File "/usr/bin/pulp-client", line 100, in <module>
    PulpRegister().main()
  File "/usr/lib/python2.6/site-packages/pulptools/pulpcli.py", line 108, in main
    cmd.main()
  File "/usr/lib/python2.6/site-packages/pulptools/core/basecore.py", line 115, in main
    self._do_core()
  File "/usr/lib/python2.6/site-packages/pulptools/core/core_consumer.py", line 112, in _do_core
    self._create()
  File "/usr/lib/python2.6/site-packages/pulptools/core/core_consumer.py", line 135, in _create
    consumer = self.cconn.create(self.options.id, self.options.description)
  File "/usr/lib/python2.6/site-packages/pulptools/connection.py", line 265, in create
    return self.conn.request_put(method, params=consumerdata)
  File "/usr/lib/python2.6/site-packages/pulptools/connection.py", line 108, in request_put
    return self._request("PUT", method, params)
  File "/usr/lib/python2.6/site-packages/pulptools/connection.py", line 83, in _request
    headers=self.headers)
  File "/usr/lib64/python2.6/httplib.py", line 898, in request
    self._send_request(method, url, body, headers)
  File "/usr/lib64/python2.6/httplib.py", line 935, in _send_request
    self.endheaders()
  File "/usr/lib64/python2.6/httplib.py", line 892, in endheaders
    self._send_output()
  File "/usr/lib64/python2.6/httplib.py", line 764, in _send_output
    self.send(msg)
  File "/usr/lib64/python2.6/httplib.py", line 723, in send
    self.connect()
  File "/usr/lib64/python2.6/site-packages/M2Crypto/httpslib.py", line 50, in connect
    self.sock.connect((self.host, self.port))
  File "/usr/lib64/python2.6/site-packages/M2Crypto/SSL/Connection.py", line 184, in connect
    if not check(self.get_peer_cert(), self.addr[0]):
  File "/usr/lib64/python2.6/site-packages/M2Crypto/SSL/Checker.py", line 123, in __call__
    fieldName='commonName')
M2Crypto.SSL.Checker.WrongHost: Peer certificate commonName does not match host, expected preethi.usersys.redhat.com, got localhost


[root@preethi pulp]# pulp-admin -u admin -p admin consumer list
Traceback (most recent call last):
  File "/usr/bin/pulp-admin", line 30, in <module>
    pulpcli.PulpCore().main()
  File "/usr/lib/python2.6/site-packages/pulptools/pulpcli.py", line 108, in main
    cmd.main()
  File "/usr/lib/python2.6/site-packages/pulptools/core/basecore.py", line 115, in main
    self._do_core()
  File "/usr/lib/python2.6/site-packages/pulptools/core/core_consumer.py", line 114, in _do_core
    self._list()
  File "/usr/lib/python2.6/site-packages/pulptools/core/core_consumer.py", line 187, in _list
    cons = self.cconn.consumers()
  File "/usr/lib/python2.6/site-packages/pulptools/connection.py", line 301, in consumers
    return self.conn.request_get(method)
  File "/usr/lib/python2.6/site-packages/pulptools/connection.py", line 99, in request_get
    return self._request("GET", method)
  File "/usr/lib/python2.6/site-packages/pulptools/connection.py", line 83, in _request
    headers=self.headers)
  File "/usr/lib64/python2.6/httplib.py", line 898, in request
    self._send_request(method, url, body, headers)
  File "/usr/lib64/python2.6/httplib.py", line 935, in _send_request
    self.endheaders()
  File "/usr/lib64/python2.6/httplib.py", line 892, in endheaders
    self._send_output()
  File "/usr/lib64/python2.6/httplib.py", line 764, in _send_output
    self.send(msg)
  File "/usr/lib64/python2.6/httplib.py", line 723, in send
    self.connect()
  File "/usr/lib64/python2.6/site-packages/M2Crypto/httpslib.py", line 50, in connect
    self.sock.connect((self.host, self.port))
  File "/usr/lib64/python2.6/site-packages/M2Crypto/SSL/Connection.py", line 184, in connect
    if not check(self.get_peer_cert(), self.addr[0]):
  File "/usr/lib64/python2.6/site-packages/M2Crypto/SSL/Checker.py", line 123, in __call__
    fieldName='commonName')
M2Crypto.SSL.Checker.WrongHost: Peer certificate commonName does not match host, expected preethi.usersys.redhat.com, got localhost



[root@preethi pulp]# pulp-admin -u admin -p admin consumer delete --id=preethi
Traceback (most recent call last):
  File "/usr/bin/pulp-admin", line 30, in <module>
    pulpcli.PulpCore().main()
  File "/usr/lib/python2.6/site-packages/pulptools/pulpcli.py", line 108, in main
    cmd.main()
  File "/usr/lib/python2.6/site-packages/pulptools/core/basecore.py", line 115, in main
    self._do_core()
  File "/usr/lib/python2.6/site-packages/pulptools/core/core_consumer.py", line 118, in _do_core
    self._delete()
  File "/usr/lib/python2.6/site-packages/pulptools/core/core_consumer.py", line 238, in _delete
    self.cconn.delete(consumerid)
  File "/usr/lib/python2.6/site-packages/pulptools/connection.py", line 277, in delete
    return self.conn.request_delete(method)
  File "/usr/lib/python2.6/site-packages/pulptools/connection.py", line 111, in request_delete
    return self._request("DELETE", method)
  File "/usr/lib/python2.6/site-packages/pulptools/connection.py", line 83, in _request
    headers=self.headers)
  File "/usr/lib64/python2.6/httplib.py", line 898, in request
    self._send_request(method, url, body, headers)
  File "/usr/lib64/python2.6/httplib.py", line 935, in _send_request
    self.endheaders()
  File "/usr/lib64/python2.6/httplib.py", line 892, in endheaders
    self._send_output()
  File "/usr/lib64/python2.6/httplib.py", line 764, in _send_output
    self.send(msg)
  File "/usr/lib64/python2.6/httplib.py", line 723, in send
    self.connect()
  File "/usr/lib64/python2.6/site-packages/M2Crypto/httpslib.py", line 50, in connect
    self.sock.connect((self.host, self.port))
  File "/usr/lib64/python2.6/site-packages/M2Crypto/SSL/Connection.py", line 184, in connect
    if not check(self.get_peer_cert(), self.addr[0]):
  File "/usr/lib64/python2.6/site-packages/M2Crypto/SSL/Checker.py", line 123, in __call__
    fieldName='commonName')
M2Crypto.SSL.Checker.WrongHost: Peer certificate commonName does not match host, expected preethi.usersys.redhat.com, got localhost

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Shveta 2010-08-17 08:39:38 EDT
[root@shveta noarch]# pulp-client -u admin -p admin consumer create --id=1-.65.193.75
Traceback (most recent call last):
  File "/usr/bin/pulp-client", line 100, in <module>
    PulpRegister().main()
  File "/usr/lib/python2.6/site-packages/pulptools/pulpcli.py", line 108, in main
    cmd.main()
  File "/usr/lib/python2.6/site-packages/pulptools/core/basecore.py", line 115, in main
    self._do_core()
  File "/usr/lib/python2.6/site-packages/pulptools/core/core_consumer.py", line 112, in _do_core
    self._create()
  File "/usr/lib/python2.6/site-packages/pulptools/core/core_consumer.py", line 135, in _create
    consumer = self.cconn.create(self.options.id, self.options.description)
  File "/usr/lib/python2.6/site-packages/pulptools/connection.py", line 265, in create
    return self.conn.request_put(method, params=consumerdata)
  File "/usr/lib/python2.6/site-packages/pulptools/connection.py", line 108, in request_put
    return self._request("PUT", method, params)
  File "/usr/lib/python2.6/site-packages/pulptools/connection.py", line 83, in _request
    headers=self.headers)
  File "/usr/lib64/python2.6/httplib.py", line 874, in request
    self._send_request(method, url, body, headers)
  File "/usr/lib64/python2.6/httplib.py", line 911, in _send_request
    self.endheaders()
  File "/usr/lib64/python2.6/httplib.py", line 868, in endheaders
    self._send_output()
  File "/usr/lib64/python2.6/httplib.py", line 740, in _send_output
    self.send(msg)
  File "/usr/lib64/python2.6/httplib.py", line 699, in send
    self.connect()
  File "/usr/lib64/python2.6/site-packages/M2Crypto/httpslib.py", line 50, in connect
    self.sock.connect((self.host, self.port))
  File "/usr/lib64/python2.6/site-packages/M2Crypto/SSL/Connection.py", line 177, in connect
    self.socket.connect(addr)
  File "<string>", line 1, in connect
socket.error: [Errno 111] Connection refused

=========================================================

[root@shveta noarch]# pulp-admin -u admin -p admin repo list
Traceback (most recent call last):
  File "/usr/bin/pulp-admin", line 30, in <module>
    pulpcli.PulpCore().main()
  File "/usr/lib/python2.6/site-packages/pulptools/pulpcli.py", line 108, in main
    cmd.main()
  File "/usr/lib/python2.6/site-packages/pulptools/core/basecore.py", line 115, in main
    self._do_core()
  File "/usr/lib/python2.6/site-packages/pulptools/core/core_repo.py", line 108, in _do_core
    self._list()
  File "/usr/lib/python2.6/site-packages/pulptools/core/core_repo.py", line 151, in _list
    repos = self.pconn.repositories()
  File "/usr/lib/python2.6/site-packages/pulptools/connection.py", line 170, in repositories
    return self.conn.request_get(method)
  File "/usr/lib/python2.6/site-packages/pulptools/connection.py", line 99, in request_get
    return self._request("GET", method)
  File "/usr/lib/python2.6/site-packages/pulptools/connection.py", line 83, in _request
    headers=self.headers)
  File "/usr/lib64/python2.6/httplib.py", line 874, in request
    self._send_request(method, url, body, headers)
  File "/usr/lib64/python2.6/httplib.py", line 911, in _send_request
    self.endheaders()
  File "/usr/lib64/python2.6/httplib.py", line 868, in endheaders
    self._send_output()
  File "/usr/lib64/python2.6/httplib.py", line 740, in _send_output
    self.send(msg)
  File "/usr/lib64/python2.6/httplib.py", line 699, in send
    self.connect()
  File "/usr/lib64/python2.6/httplib.py", line 1072, in connect
    sock = socket.create_connection((self.host, self.port), self.timeout)
  File "/usr/lib64/python2.6/socket.py", line 512, in create_connection
    raise error, msg
socket.error: [Errno 111] Connection refused
[root@shveta noarch]# rpm -q pulp
pulp-0.0.50-1.git.7.ecb6917.fc12.noarch
[root@shveta noarch]# rpm -q pulp-tools
pulp-tools-0.0.50-1.git.7.ecb6917.fc12.noarch
Comment 2 Pradeep Kilambi 2010-08-17 11:01:05 EDT

*** This bug has been marked as a duplicate of bug 624083 ***

Note You need to log in before you can comment on or make changes to this bug.