Bug 624192 - Cannot install kmod-kvm because of failed kernel pacakge dependencies that cannot be resolved
Cannot install kmod-kvm because of failed kernel pacakge dependencies that ca...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Eduardo Habkost
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-08-14 03:49 EDT by anna.fischer
Modified: 2010-11-09 08:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-02 03:51:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description anna.fischer 2010-08-14 03:49:54 EDT
Description of problem: 
I cannot install KVM on my RHEL 5.5 installation, because of failed dependencies, that I do not seem to be able to resolve at all:

# yum install kvm*
Excluding Packages from RedHat-5Server-noarch-errata
Finished
Excluding Packages from RedHat-5Server-x86_64-errata
Finished
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package kvm.x86_64 0:83-164.el5_5.15 set to be updated
--> Processing Dependency: etherboot-zroms-kvm >= 5.4.4-13.el5 for package: kvm
--> Processing Dependency: qspice-libs for package: kvm
--> Processing Dependency: kmod-kvm for package: kvm
--> Processing Dependency: libqcairo.so.2()(64bit) for package: kvm
--> Processing Dependency: libspice.so.0()(64bit) for package: kvm
--> Processing Dependency: libcelt051.so.0()(64bit) for package: kvm
--> Processing Dependency: libqavutil.so.49()(64bit) for package: kvm
--> Processing Dependency: libqavcodec.so.51()(64bit) for package: kvm
---> Package kvm-qemu-img.x86_64 0:83-164.el5_5.15 set to be updated
---> Package kvm-tools.x86_64 0:83-164.el5_5.15 set to be updated
--> Running transaction check
---> Package celt051.x86_64 0:0.5.1.3-0.el5 set to be updated
---> Package etherboot-zroms-kvm.x86_64 0:5.4.4-13.el5 set to be updated
---> Package kmod-kvm.x86_64 0:83-164.el5_5.15 set to be updated
--> Processing Dependency: kernel(rhel5_arch_x86_64_kernel_u4) = e40e507485dfb99d1a6480bfb679e7afb3bc1a8c for package: kmod-kvm
--> Processing Dependency: kernel(rhel5_fs_u4) = 518e7b7963ed0843e4b55b64ba2b25db95cf821a for package: kmod-kvm
--> Processing Dependency: kernel(rhel5_fs_u2) = bcdb03d0c4f4b6a03aaac45299f4f7e7ebcf1707 for package: kmod-kvm
--> Processing Dependency: kernel(rhel5_kernel_u4) = 8ab615e813e8850bbb96ce58341e9d0821384231 for package: kmod-kvm
--> Processing Dependency: kernel(rhel5_arch_x86_64_kernel_u2) = 12cc0c2f515fd81b2da9071974dc948e339f09cd for package: kmod-kvm
---> Package qcairo.x86_64 0:1.8.7.1-3.el5 set to be updated
--> Processing Dependency: libqpixman-1.so.0()(64bit) for package: qcairo
---> Package qffmpeg-libs.x86_64 0:0.4.9-0.16.20080908.el5_5 set to be updated
---> Package qspice-libs.x86_64 0:0.3.0-54.el5_5.1 set to be updated
--> Running transaction check
---> Package kmod-kvm.x86_64 0:83-164.el5_5.15 set to be updated
--> Processing Dependency: kernel(rhel5_arch_x86_64_kernel_u4) = e40e507485dfb99d1a6480bfb679e7afb3bc1a8c for package: kmod-kvm
--> Processing Dependency: kernel(rhel5_fs_u4) = 518e7b7963ed0843e4b55b64ba2b25db95cf821a for package: kmod-kvm
--> Processing Dependency: kernel(rhel5_fs_u2) = bcdb03d0c4f4b6a03aaac45299f4f7e7ebcf1707 for package: kmod-kvm
--> Processing Dependency: kernel(rhel5_kernel_u4) = 8ab615e813e8850bbb96ce58341e9d0821384231 for package: kmod-kvm
--> Processing Dependency: kernel(rhel5_arch_x86_64_kernel_u2) = 12cc0c2f515fd81b2da9071974dc948e339f09cd for package: kmod-kvm
---> Package qpixman.x86_64 0:0.13.3-4.el5 set to be updated
--> Finished Dependency Resolution
kmod-kvm-83-164.el5_5.15.x86_64 from RedHat-5Server-x86_64-errata has depsolving problems
  --> Missing Dependency: kernel(rhel5_kernel_u4) = 8ab615e813e8850bbb96ce58341e9d0821384231 is needed by package kmod-kvm-83-164.el5_5.15.x86_64 (RedHat-5Server-x86_64-errata)
kmod-kvm-83-164.el5_5.15.x86_64 from RedHat-5Server-x86_64-errata has depsolving problems
  --> Missing Dependency: kernel(rhel5_arch_x86_64_kernel_u2) = 12cc0c2f515fd81b2da9071974dc948e339f09cd is needed by package kmod-kvm-83-164.el5_5.15.x86_64 (RedHat-5Server-x86_64-errata)
kmod-kvm-83-164.el5_5.15.x86_64 from RedHat-5Server-x86_64-errata has depsolving problems
  --> Missing Dependency: kernel(rhel5_arch_x86_64_kernel_u4) = e40e507485dfb99d1a6480bfb679e7afb3bc1a8c is needed by package kmod-kvm-83-164.el5_5.15.x86_64 (RedHat-5Server-x86_64-errata)
kmod-kvm-83-164.el5_5.15.x86_64 from RedHat-5Server-x86_64-errata has depsolving problems
  --> Missing Dependency: kernel(rhel5_fs_u4) = 518e7b7963ed0843e4b55b64ba2b25db95cf821a is needed by package kmod-kvm-83-164.el5_5.15.x86_64 (RedHat-5Server-x86_64-errata)
kmod-kvm-83-164.el5_5.15.x86_64 from RedHat-5Server-x86_64-errata has depsolving problems
  --> Missing Dependency: kernel(rhel5_fs_u2) = bcdb03d0c4f4b6a03aaac45299f4f7e7ebcf1707 is needed by package kmod-kvm-83-164.el5_5.15.x86_64 (RedHat-5Server-x86_64-errata)
Error: Missing Dependency: kernel(rhel5_kernel_u4) = 8ab615e813e8850bbb96ce58341e9d0821384231 is needed by package kmod-kvm-83-164.el5_5.15.x86_64 (RedHat-5Server-x86_64-errata)
Error: Missing Dependency: kernel(rhel5_fs_u4) = 518e7b7963ed0843e4b55b64ba2b25db95cf821a is needed by package kmod-kvm-83-164.el5_5.15.x86_64 (RedHat-5Server-x86_64-errata)
Error: Missing Dependency: kernel(rhel5_arch_x86_64_kernel_u4) = e40e507485dfb99d1a6480bfb679e7afb3bc1a8c is needed by package kmod-kvm-83-164.el5_5.15.x86_64 (RedHat-5Server-x86_64-errata)
Error: Missing Dependency: kernel(rhel5_arch_x86_64_kernel_u2) = 12cc0c2f515fd81b2da9071974dc948e339f09cd is needed by package kmod-kvm-83-164.el5_5.15.x86_64 (RedHat-5Server-x86_64-errata)
Error: Missing Dependency: kernel(rhel5_fs_u2) = bcdb03d0c4f4b6a03aaac45299f4f7e7ebcf1707 is needed by package kmod-kvm-83-164.el5_5.15.x86_64 (RedHat-5Server-x86_64-errata)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

I have tried removing and reinstalling the kernel packages, and all other packages that are part of the dependency problem, but nothing help to have this fixed and have the kvm packages being installed.

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. Run yum install kvm.
2.
3.
  
Actual results:
Dependency errors prevent installation to succeed.

Expected results:
Installation should work.

Additional info:

# yum list kernel
Excluding Packages from RedHat-5Server-noarch-errata
Finished
Excluding Packages from RedHat-5Server-x86_64-errata
Finished
Installed Packages
kernel.x86_64                                     2.6.18-8.el5                                     installed

# yum info kernel
Excluding Packages from RedHat-5Server-noarch-errata
Finished
Excluding Packages from RedHat-5Server-x86_64-errata
Finished
Installed Packages
Name       : kernel
Arch       : x86_64
Version    : 2.6.18
Release    : 8.el5
Size       : 72 M
Repo       : installed
Summary    : The Linux kernel (the core of the Linux operating system)
License    : GPLv2
Description: The kernel package contains the Linux kernel (vmlinuz), the core of any
           : Linux operating system.  The kernel handles the basic functions
           : of the operating system:  memory allocation, process allocation, device
           : input and output, etc.

# yum info kmod-kvm
Excluding Packages from RedHat-5Server-noarch-errata
Finished
Excluding Packages from RedHat-5Server-x86_64-errata
Finished
Available Packages
Name       : kmod-kvm
Arch       : x86_64
Version    : 83
Release    : 164.el5_5.15
Size       : 1.2 M
Repo       : RedHat-5Server-x86_64-errata
Summary    : kvm kernel module(s)
URL        : http://kvm.sf.net
License    : GPLv2
Description: This package provides the kvm kernel modules built for the Linux
           : kernel 2.6.18-194.8.1.el5 for the x86_64 family of processors.
Comment 1 anna.fischer 2010-09-02 03:51:36 EDT
This is fixed by pointing at a different RHEL package repository server, so it does not seem to be broken in RHEL itself.

I would suggest to close the bug for this reason.

Note You need to log in before you can comment on or make changes to this bug.