Bug 624195 - Error: this function is not supported by the connection driver: virDomainReboot
Summary: Error: this function is not supported by the connection driver: virDomainReboot
Status: CLOSED DUPLICATE of bug 532216
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager   
(Show other bugs)
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-14 09:32 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2010-08-21 22:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-21 22:07:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dominik 'Rathann' Mierzejewski 2010-08-14 09:32:06 UTC
Description of problem:
virt-manager shows a traceback:

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 637, in reboot_domain
    vm.reboot()
  File "/usr/share/virt-manager/virtManager/domain.py", line 146, in reboot
    self._backend.reboot(0)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 591, in reboot
    if ret == -1: raise libvirtError ('virDomainReboot() failed', dom=self)
libvirtError: this function is not supported by the connection driver: virDomainReboot

My F-14 vm got into a weird state after telinit 1, the console went blank so I wanted to reboot it. Using Shut down -> Reboot resulted in the above error.

Version-Release number of selected component (if applicable):
virt-manager-0.8.2-3.fc12.noarch

How reproducible:
Always

Steps to Reproduce:
1. start f14 vm
2. startx, open terminal, become root
3. init 1, wait until console goes black
4. select Shut down -> Reboot in virt-manager

Comment 1 Paul Jenner 2010-08-21 18:56:14 UTC
Looks like a duplicate of bug #532216 that looks like it was fixed in F13 but not sure if an update went to F12

Comment 2 Cole Robinson 2010-08-21 22:07:26 UTC
libvirt actually doesn't support a native 'reboot' option for KVM. In virt-manager in F13 we kind of fake it, but I don't plan on backporting this to F12. Closing as a dupe of 532216

*** This bug has been marked as a duplicate of bug 532216 ***


Note You need to log in before you can comment on or make changes to this bug.