Bug 624213 - bash error
bash error
Status: CLOSED DUPLICATE of bug 623908
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-14 10:38 EDT by Brandon
Modified: 2014-01-12 19:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-23 10:32:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brandon 2010-08-14 10:38:47 EDT
I'm not sure what is wrong.... just reporting the error.


Summary:

SELinux is preventing /bin/bash access to a leaked /root file descriptor.

Detailed Description:

[prelink has a permissive type (prelink_cron_system_t). This access was not
denied.]

SELinux denied access requested by the prelink command. It looks like this is
either a leaked descriptor or prelink output was redirected to a file it is not
allowed to access. Leaks usually can be ignored since SELinux is just closing
the leak and reporting the error. The application does not use the descriptor,
so it will run properly. If this is a redirection, you will not get output in
the /root. You should generate a bugzilla on selinux-policy, and it will get
routed to the appropriate package. You can safely ignore this avc.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385)

Additional Information:

Source Context                system_u:system_r:prelink_cron_system_t:s0-s0:c0.c
                              1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                /root [ dir ]
Source                        prelink
Source Path                   /bin/bash
Port                          <Unknown>
Host                          localhost.localdomain
Source RPM Packages           bash-4.1.7-1.fc13
Target RPM Packages           filesystem-2.4.31-1.fc13
Policy RPM                    selinux-policy-3.7.19-44.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   leaks
Host Name                     localhost.localdomain
Platform                      Linux localhost.localdomain
                              2.6.33.6-147.2.4.fc13.x86_64 #1 SMP Fri Jul 23
                              17:14:44 UTC 2010 x86_64 x86_64
Alert Count                   2
First Seen                    Fri 13 Aug 2010 11:25:12 AM EDT
Last Seen                     Sat 14 Aug 2010 10:33:11 AM EDT
Local ID                      680d0b08-669b-4a30-88e0-012274ab2418
Line Numbers                  

Raw Audit Messages            

node=localhost.localdomain type=AVC msg=audit(1281796391.918:29): avc:  denied  { read } for  pid=3626 comm="prelink" path="/root" dev=dm-0 ino=655361 scontext=system_u:system_r:prelink_cron_system_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=dir

node=localhost.localdomain type=SYSCALL msg=audit(1281796391.918:29): arch=c000003e syscall=59 success=yes exit=0 a0=cb5860 a1=cb5ff0 a2=cb5530 a3=10 items=0 ppid=3481 pid=3626 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=2 comm="prelink" exe="/bin/bash" subj=system_u:system_r:prelink_cron_system_t:s0-s0:c0.c1023 key=(null)
Comment 1 Roman Rakus 2010-08-16 03:24:17 EDT
What were you trying to do?
Anyway, adding selinux guy...
Comment 2 Daniel Walsh 2010-08-23 10:32:40 EDT
This is a cron bug and should be fixed in the latest version of cronnie.

yum update cronnie --enable-repo=updates-testing
Comment 3 Daniel Walsh 2010-08-23 10:36:44 EDT

*** This bug has been marked as a duplicate of bug 623908 ***

Note You need to log in before you can comment on or make changes to this bug.