Bug 62429 - yppush times out although ypxfr status is "Success"
yppush times out although ypxfr status is "Success"
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: ypserv (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Aaron Brown
:
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-03-31 17:57 EST by Bernhard Weisshuhn
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-05 12:32:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernhard Weisshuhn 2002-03-31 17:57:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020326

Description of problem:
When pushing a map from the server to the slaves, yppush always times out with
"Callback timed out", even though the "Status received from ypxfr" says
"Success" (visible with args -vv to yppush).

Version-Release number of selected component (if applicable): 2.2-3


How reproducible:
Always

Steps to Reproduce:
1. set up two ypservers with ypserv-2.2-3 and ypinit both of them
2. check that normal transfers are working
3. run slave ypserv with --debug (not neccessary to reproduce but interesting)
4. on the master: /usr/sbin/yppush -vv passwd.byuid (or any other map)
   (or set NOPUSH=false in /var/yp/Makefile on the master and use 'make')

	

Actual Results:  I'm adding -h here since I have more slaves, but this doesn't
affect the behaviour:

root@ypmaster# /usr/sbin/yppush -h ypslave.myplace.net -vv passwd.byuid
Start new child (1)yppush_foreach: host=ypslave.myplace.net

ypslave.myplace.net has been called.
        ->target: ypslave.myplace.net
        ->domain: myplace.net
        ->map: passwd.byuid
        ->tarnsid: 2233
        ->prog: 1073741824
        ->master: ypmaster.myplace.net
        ->ordernum: 1017613849
yppush_xfrrespprog_1
yppushproc_xfrresp_1_svc
Status received from ypxfr on ypslave.myplace.net:
        Transfer not done: Master's version not newer
Running Children: 1
Running Children: 1
Running Children: 1
Running Children: 1
Running Children: 1
Running Children: 1
Running Children: 1
Running Children: 1
passwd.byuid->ypslave.myplace.net: Callback timed out
Child 1 exists
Running Children: 0
all done (0 running childs)

After the (immediate) response from ypslaves's ypxfr yppush just sits there and
waits until it times out. This takes a whole minute per host if you don't fiddle
with -t and -p options to yppush.

Additional info:

It does _not_ depend on whether the maps have changed or not. If they have been
changed, the output is basically the same, only does ypxfr respond with
'Transfer done: Success' instead of 'Transfer not done: Master's version not
newer'. yppush times out after waiting for its children just the same.

Using ypxfrd doesn't seem to make any difference.

The maps _are_ transfered, but the timeout-warning is somewhat misleading,
annoying and scary (since we're dealing with auth-data).
Comment 1 Alexander Larsson 2002-04-05 12:32:15 EST
Ok. I've reproduced this. Will look into it.
Comment 2 Alexander Larsson 2002-04-05 16:31:12 EST
Fixed in ypserv-2.2-7. Will hit rawhide at the next sync.

Note You need to log in before you can comment on or make changes to this bug.