Bug 624309 - Kernel update breaks ATI dual monitor setup
Kernel update breaks ATI dual monitor setup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-15 19:44 EDT by srh
Modified: 2010-08-27 01:52 EDT (History)
8 users (show)

See Also:
Fixed In Version: 2.6.33.8-149.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-27 01:52:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description srh 2010-08-15 19:44:54 EDT
Description of problem:
Standard install of Fedora 13 x64. Fully updated (16 Aug 2010).

I have two LCD screens (Philips 19inch, 1280x1024, both with DVI connectors) attached to an ATI video card. The screens are set up as one big desktop (left and right). Using the default Fedora opensource ATI video driver.

When booting with kernel 2.6.33.6-147.2.4.fc13.x86_64, each screen now mirrors each other with a desktop that is sized to just one screen ie. the first screen shows a desktop that is 1280x1024, the second screen is a mirror of the first screen. Using 'Monitor Preferences' GUI shows only one screen available, even after pressing 'Detect monitors'.

When booting with the previous kernel 2.6.33.6-147.fc13.x86_64, one big desktop spread across the two screens works fine (and has done so since Fedora 13 first came out). 'Monitor Preferences' GUI shows two screen available for adjustment.


Version-Release number of selected component (if applicable):

Broken dual monitor support - 2.6.33.6-147.2.4.fc13.x86_64
Working dual monitor support - 2.6.33.6-147.fc13.x86_64 (and all previous F13 kernels).

From Xorg.0.log:
[    22.914] (--) PCI:*(0:1:0:0) 1002:944c:1043:0280 ATI Technologies Inc RV770 LE [Radeon HD 4800 Series] rev 0, Mem @ 0xd0000000/268435456, 0xe0200000/65536, I/O @ 0x00002000/256, BIOS @ 0x????????/131072


How reproducible:
Always
Comment 1 Chuck Ebbert 2010-08-17 07:31:29 EDT
This was probably broken in -147.2.3 by drm-radeon-fix-shared-ddc-handling.patch and is fixed properly in 2.6.34.2 and 2.6.33.7 . Can you try 2.6.34.3-37 from the updates-testing repository?
Comment 2 Chuck Ebbert 2010-08-18 08:57:17 EDT
I'm going to assume this is fixed in 2.6.33.7
Comment 3 srh 2010-08-18 20:45:53 EDT
I installed:
kernel-2.6.33.8-149.fc13.x86_64 (from koji)
and
kernel-2.6.34.3-37.fc13.x86_64 (from updates-testing)

Both kernels fix this bug.

Thanks. Closing bug.
Comment 4 Chuck Ebbert 2010-08-19 06:46:37 EDT
We'll let Bodhi close the bug when the kernel gets released.

Note You need to log in before you can comment on or make changes to this bug.