Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 624344 - do not use a semarg in shared-mem for semop calls
do not use a semarg in shared-mem for semop calls
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
5.5
All Linux
high Severity high
: rc
: ---
Assigned To: Mike Christie
Red Hat Kernel QE team
: ZStream
Depends On:
Blocks: 632094
  Show dependency treegraph
 
Reported: 2010-08-16 00:07 EDT by Wade Mealing
Modified: 2011-01-13 17:58 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Due to iscsid sharing the "semarg" structure between multiple devices, a deadlock may have occurred when logging was initiated. With this update, each process is assigned its own structure, so that such deadlocks no longer occur.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 17:58:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0072 normal SHIPPED_LIVE iscsi-initiator-utils bug fix update 2011-01-12 12:22:06 EST

  None (edit)
Description Wade Mealing 2010-08-16 00:07:59 EDT
Description of problem:

Each process must have its own semarg structure - or they step on each
others' toes - which could cause either deadlocks or smearing of the shared
memory protected by the semaphore.

Version-Release number of selected component (if applicable):

iscsi-initiator-utils-6.2.0.871-0.18.fc12.src.rpm (Anything based on 871 series).

How reproducible:

Unknown.


Steps to Reproduce:
1. Configure the iscsi initator util with at least two target devices.
2. Configure it to the maximum amount of logging
3. ?????

  
Actual results:

Logging can possibly cause a deadlock in waiting for semaphore access.

Expected results:

No deadlock to occur.

Additional info:

This is a backport of the patch from : http://git.kernel.org/?p=linux/kernel/git/mnc/open-iscsi.git;a=commitdiff;h=b95a7ca80b255f0c5b34b2669367b629c8489552;hp=fb4f2d3072bee96606d01e3535c100dc99b8d331  to the 871 series.

Mike Christie posted Guy Kerens patch (I think).  This patch is already in the EL6 build.
Comment 2 RHEL Product and Program Management 2010-08-16 00:17:19 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 Mike Christie 2010-08-16 17:11:45 EDT
I am going to resync the iscsi package to the upstream/rhel6 version, so this will get brought in.

Thanks for the patch and report.
Comment 4 Issue Tracker 2010-08-16 20:26:24 EDT
Event posted on 2010-08-17 09:26 JST by fuchi

G'day Wade,

A bugzilla has been opened, thank you so much!!
And here is a HotFix request. please approve this request.

http://seg.rdu.redhat.com/scripts/hotfix/edit.pl?id=5453

Kind regards,
Fuchi


This event sent from IssueTracker by fuchi 
 issue 1256153
Comment 9 Mike Christie 2010-08-31 22:51:17 EDT
Fixed in iscsi-initiator-utils-6.2.0.871-0.19:
http://people.redhat.com/mchristi/iscsi/rhel5.5.z/iscsi-initiator-utils/
This is what I am making for 5.5.z.
Comment 14 michal novacek 2010-09-22 05:39:10 EDT
Patch is included as iscsi-initiator-utils-fix-semop-log.patch in iscsi-initiator-utils-6.2.0.871-0.20.el5 and compiles correctly.
Comment 15 Florian Nadge 2010-11-23 08:22:09 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
* Previously, the open-iscsi administration utility (iscsiadm) sent incorrect initiator task tags (ITT) when encountering a multi-PDU This caused the discovery to fail. With this update, the ITT initialization and allocation sends the correct tags and iscsiadm works as expected. (BZ#633122)
Comment 16 Florian Nadge 2010-11-23 08:22:51 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-* Previously, the open-iscsi administration utility (iscsiadm) sent incorrect initiator task tags (ITT) when encountering a multi-PDU This caused the discovery to fail. With this update, the ITT initialization and allocation sends the correct tags and iscsiadm works as expected. (BZ#633122)+Previously, iscsid shared the 'semarg' structure between multiple devices and could cause a deadlock when waiting for the semaphore access. With this update, each process is assigned its own structure and deadlocks no longer occur.
Comment 17 Florian Nadge 2010-11-23 08:23:14 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Previously, iscsid shared the 'semarg' structure between multiple devices and could cause a deadlock when waiting for the semaphore access. With this update, each process is assigned its own structure and deadlocks no longer occur.+Previously, iscsid shared the 'semarg' structure between multiple devices and thus caused a deadlock to occur when logging was initiated. With this update, each process is assigned its own structure and deadlocks no longer occurs during the logging process.
Comment 18 Jaromir Hradilek 2010-12-08 05:57:26 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Previously, iscsid shared the 'semarg' structure between multiple devices and thus caused a deadlock to occur when logging was initiated. With this update, each process is assigned its own structure and deadlocks no longer occurs during the logging process.+Due to iscsid sharing the "semarg" structure between multiple devices, a deadlock may have occurred when logging was initiated. With this update, each process is assigned its own structure, so that such deadlocks no longer occur.
Comment 20 errata-xmlrpc 2011-01-13 17:58:48 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0072.html

Note You need to log in before you can comment on or make changes to this bug.