Bug 624377 - Hardware Info of the registered system is shortened
Summary: Hardware Info of the registered system is shortened
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
(Show other bugs)
Version: 540
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Tomas Lestach
QA Contact: Dimitar Yordanov
URL:
Whiteboard:
Keywords:
Depends On: 625727
Blocks: sat540-blockers
TreeView+ depends on / blocked
 
Reported: 2010-08-16 08:23 UTC by Garik Khachikyan
Modified: 2015-01-04 21:57 UTC (History)
5 users (show)

Fixed In Version: spacewalk-java-1.2.18-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-28 14:57:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
HW page - look at the bottom (147.26 KB, image/png)
2010-08-16 08:23 UTC, Garik Khachikyan
no flags Details
no hw info (65.04 KB, image/png)
2010-08-24 14:20 UTC, Garik Khachikyan
no flags Details
dmi info issue (29.93 KB, image/png)
2010-08-25 14:05 UTC, Garik Khachikyan
no flags Details

Description Garik Khachikyan 2010-08-16 08:23:38 UTC
Created attachment 438909 [details]
HW page - look at the bottom

Description of problem:
In older versions of SW I used to see the Hardware Info for registered system in more details (like Networking info, Storage, Video, USB, Misc...).
All these info is now missing in the SW 1.1 release.

Version-Release number of selected component (if applicable):
SW 1.1

How reproducible:
always.

Steps to Reproduce:
1. register any system (physical or virtual, does not matter)
2. refer to /network/systems/details/hardware.pxt?sid=<SID>
3.
  
Actual results:
very limited info about the HW

Expected results:
more detailed info (like network devices, USBs, VCard, etc.)

Additional info:

Comment 1 Garik Khachikyan 2010-08-16 08:24:26 UTC
# COMMENT

I think it's an urgent issue and needs to be fixed in SW 1.1 (included in coming Satellite release as well)

Comment 2 Garik Khachikyan 2010-08-16 08:38:28 UTC
# COMMENT

And one more issue:

In the "Bios" field of the HW info there seems is pushing python object instance and not the value:
.

For example on registered system one can see: "com.redhat.rhn.domain.server.Dmi$Bios@9afbe560"

It would be better displaying the info insted: "Phoenix Technologies LTD 
3E01 - 06/30/2004"

Comment 3 Michael Mráka 2010-08-16 08:58:24 UTC
IMHO this is a result of python-hwdata change. Reassigning to client component.

Comment 6 Colin Coe 2010-08-24 00:36:04 UTC
I think this is my bad.  I converted the PXT page to Java and some detail fell off.  This was corrected a week or so in git so should be OK in nightly.

Garik, could you confirm the hardware URL: is it a .do or .pxt page?  If .pxt then its the old page and could be the python issue Michael Mraka mentioned.  If it's a .do then could you attach a screen shot and I'll have a look.

CC

Comment 7 Garik Khachikyan 2010-08-24 14:19:49 UTC
hi,

The page is java one: with *.do extension there.

attached is the screenshot with this.

Comment 8 Garik Khachikyan 2010-08-24 14:20:09 UTC
Created attachment 440667 [details]
no hw info

Comment 9 Colin Coe 2010-08-24 21:53:53 UTC
Yep, this one is my bad but it should be fixed in nightly.  Can you test from nightly or from git?

Comment 10 Garik Khachikyan 2010-08-25 08:49:17 UTC
hm, sorry but not now - the installer gets broken (dependency issues).
tried for F13.

Comment 11 Garik Khachikyan 2010-08-25 10:38:06 UTC
ehm, sorry for confusion: jpackage repo seems was unavail.
now it turned back to working again. will perform the installation/check against 1.2 nightly and will report soon the results. thanks.

Comment 12 Garik Khachikyan 2010-08-25 13:00:28 UTC
I confirm:

spacewalk-java-1.2.13-1.el5 is the package that fixing the issue on SW 1.2

so, team: would you please bring the fix to SAT540 please?

many thanks.

Comment 13 Garik Khachikyan 2010-08-25 13:14:22 UTC
btw: the current sat540 iso already contains the package with the fix of HW info.

but the only thing still missing is:
"com.redhat.rhn.domain.server.Dmi$Bios@9afbe560"
(see: comment#2)

Comment 14 Colin Coe 2010-08-25 13:18:35 UTC
Could I see a screen shot?

Comment 15 Garik Khachikyan 2010-08-25 13:47:04 UTC
hm, in SW 1.2 I don't see any "DMI" info at all.

and in the comment above I referred to the feature of that DMI info for sat540.

Comment 16 Colin Coe 2010-08-25 13:56:21 UTC
SW should show DMI, if there are any.  I'll have to check tomorrow as my SW devel box is toasted and I need to rebuild.  (Not sure why only RHEL5 works as a SW devel platform for me.)

Comment 17 Garik Khachikyan 2010-08-25 14:05:23 UTC
Created attachment 440949 [details]
dmi info issue

here is the issue described above:

Comment 18 Colin Coe 2010-08-27 03:11:57 UTC
I know have a patch that I'll apply around 20:00(GMT+8) when I get home.

The problem I have is BZ 627809 and BZ 627812 means I'm unable to do proper testing as I don't see proper storage device info.

On Xen guests, there is no storage device info and on HP Proliant servers, no devices show up.  I suspect that this is because of the cciss driver.  Not sure if kudzu is not picking this up, or HAL.

Comment 19 Colin Coe 2010-08-27 04:06:29 UTC
Running 'python /usr/share/rhn/up2date_client/hardware.py' on a HP Proliant G6 gives

---
'bus' : 'pci'
'driver' : 'cciss'
'pciType' : '1'
'detached' : '0'
'class' : 'RAID'
'desc' : 'Hewlett-Packard Company|Smart Array G6 controllers'

'bus' : 'pci'
'driver' : 'unknown'
'pciType' : '-1'
'device' : 'cciss/c0d0'
'detached' : '0'
'class' : 'HD'
'desc' : ''
---

Both machines are using 'rhn-client-tools-0.4.20-33.el5_5.2'

Comment 20 Colin Coe 2010-08-27 15:38:35 UTC
commit c5562a1153aa929fef027a99d94290313aa14432
Author: Colin Coe <coec@war.coesta.com>
Date:   Fri Aug 27 23:34:29 2010 +0800

    624377 - restore original functionality and information

commit 82727ccbf4e53c4bab2071e906d0b314a9b65732
Author: Colin Coe <colin.coe@gmail.com>
Date:   Fri Aug 27 13:04:09 2010 +0800

    Fix hardware page


Hopefully its all good now...

Comment 21 Clifford Perry 2010-08-30 16:12:04 UTC
Colin - thank you for your efforts on this. 

This bug is now tracking the Sat 5.4 release. I am going to re-assign this bug to a Satellite developer to move to ON_QA for formal testing as part of Sat 5.4 ISOs. 

Thanks,
Cliff.

Comment 22 Tomas Lestach 2010-08-31 16:14:11 UTC
Thank you Colin.
Since I see "DMI Info" in latest nightly, putting ON_DEV.

Comment 23 Dimitar Yordanov 2010-09-10 13:37:32 UTC
 I have just tested it on Satellite 5.4.
 I registered two host (one physical and one virtual) and all the hardware information was available, plus the BIOS field was correct as well.
 
Pakage version:
 spacewalk-java-1.2.23-1.el5sat

Dimi

Comment 24 Milan Zázrivec 2010-10-25 14:32:22 UTC
Verified in stage with spacewalk-java-1.2.39-29.el5sat -> release_pending

Comment 25 Clifford Perry 2010-10-28 14:52:16 UTC
The 5.4.0 RHN Satellite and RHN Proxy release has occurred. This issue has been resolved with this release. 


RHEA-2010:0801 - RHN Satellite Server 5.4.0 Upgrade
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10332

RHEA-2010:0803 - RHN Tools enhancement update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10333

RHEA-2010:0802 - RHN Proxy Server 5.4.0 bug fix update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10334

RHEA-2010:0800 - RHN Satellite Server 5.4.0
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10335

Docs are available:

http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/index.html 

Regards,
Clifford


Note You need to log in before you can comment on or make changes to this bug.