Bug 62438 - libnss3 potential problems with SSLv3.
libnss3 potential problems with SSLv3.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-31 20:41 EST by Ali-Reza Anghaie
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-02 08:19:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ali-Reza Anghaie 2002-03-31 20:41:03 EST
Description of Problem:

Evolution doesn't seem to care for SSLv3 much. I'm guessing it's not library
related since libssl, sasl, etc. are used for other applications that don't seem
to have this problem.

If I force my POP server to accept only SSLv3, Evolution freaks and terminates
the connection while trying to POP. Oddly, it seems to make it through the SSL
wrapper but dies at Qpopper. Other mail clients don't seem to have this problem.

What makes it more odd is that if I change the settings to SSLv2, HUP the Inetd
process, try Evolution (which will work with v2 fine), and then switch it back
to v3 (HUP Inetd again)... Evolution works. And I used Netcat and Ethereal to
verify it was all SSLv3. And it continues to work...

Until I restart Evolution and have to do the dance again. So I changed me server
to not force SSLv3 but it'd be ideal to use SSLv3 or TLS instead of SSLv2.


Version-Release number of selected component (if applicable):

evolution-1.0.2-3.i386.rpm
openssl-0.9.6b-16.i386.rpm


How Reproducible:

Always.


Steps to Reproduce:
1. Choose a SSLv3 forced POP server.
2. POP from it.
3. *bang*


Actual Results:

Unexpected end of connection. EOF, etc.


Expected Results:

I expect it to pull my mail.


Additional Information:

I haven't tried it with another POP server or IMAP. Since I don't have this
problem with other clients I'm not pointing at my server (yet).

Let me know what else you'll want/need. I didn't paste a bunch more here in case
something obvious pops out or it's a known issue. I didn't find anyting on
Evolution mailing lists to indicate as much. Which makes me think I should, just
in case, submit this over at Ximian too.

-Ali
Comment 1 Jeremy Katz 2002-03-31 23:19:54 EST
Evolution uses libnss3 from the mozilla project as opposed to openssl, which is
what is used by most projects out there.  Do you get similar behavior from
mozilla mail?
Comment 2 Ali-Reza Anghaie 2002-04-01 06:35:34 EST
Mozilla mail also exhibits the same behavior. Good call.

So is libssl/ssl3/sasl/etc. really requirements then? I guess they must be down
the chain somewhere. Anyhow.

So you're going to reassign this as a Mozilla(-nss) bug? Or I'm I entirely too
optimistic?  ;-)

-Ali
Comment 3 Jeremy Katz 2002-04-01 10:52:17 EST
Yep, the openssl backend for evolution-mail was removed around 0.99 or so due to
licensing concerns, leaving only the libnss3 one.

Since this sounds more like a libnss3 bug than evolution itself, moving to mozilla.
Comment 4 Ali-Reza Anghaie 2002-05-07 09:54:18 EDT
Problem still exists with:  
  
evolution-1.0.3-4  
mozilla-nss-0.9.9-7  
  
Just thought you'd want to know. Regards, -Ali

Note You need to log in before you can comment on or make changes to this bug.