Bug 624408 - Trying to print with gimp: only an empty page is printed
Trying to print with gimp: only an empty page is printed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-16 07:04 EDT by Joachim Backes
Modified: 2010-10-05 11:48 EDT (History)
2 users (show)

See Also:
Fixed In Version: gimp-2.6.11-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-05 09:20:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Printer properties (38.26 KB, image/jpeg)
2010-09-27 05:24 EDT, Joachim Backes
no flags Details
Example document printing an empty page (138.34 KB, image/jpeg)
2010-09-27 05:27 EDT, Joachim Backes
no flags Details

  None (edit)
Description Joachim Backes 2010-08-16 07:04:50 EDT
Description of problem:
Opening a document (for example some gif file) is done well. But if I try to print this graphic information, only an empty page is printed. If I say: print preview, the preview window indeed is empty too.

Version-Release number of selected component (if applicable):
gimp-2.6.10-3.fc14.i686

How reproducible:
always

Steps to Reproduce:
1.see description
2.
3.
  
Actual results:
see description

Expected results:
the file is printed

Additional info:
Doing the same in *F13* will print my file well! The preview is OK too.
Comment 1 Joachim Backes 2010-08-20 07:16:47 EDT
I should add that the printer is a newtork printer Lexmark-e120n
Comment 2 Joachim Backes 2010-08-20 07:38:30 EDT
sudo lpinfo -l -v
Device: uri = scsi
        class = direct
        info = SCSI Printer
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = ipp
        class = network
        info = Internet Printing Protocol (ipp)
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = http
        class = network
        info = Internet Printing Protocol (http)
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = https
        class = network
        info = Internet Printing Protocol (https)
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = lpd
        class = network
        info = LPD/LPR Host or Printer
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = socket
        class = network
        info = AppSocket/HP JetDirect
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = dnssd://Lexmark%20E120n._printer._tcp.local/
        class = network
        info = Lexmark E120n
        make-and-model = Lexmark Lexmark E120n
        device-id = MFG:Lexmark;MDL:E120n;FZY:1;
        location = 
Device: uri = dnssd://Lexmark%20E120n._ipp._tcp.local/
        class = network
        info = Lexmark E120n
        make-and-model = Lexmark Lexmark E120n
        device-id = MFG:Lexmark;MDL:E120n;FZY:1;
        location = 
Device: uri = dnssd://Lexmark%20E120n._pdl-datastream._tcp.local/
        class = network
        info = Lexmark E120n
        make-and-model = Lexmark Lexmark E120n
        device-id = MFG:Lexmark;MDL:E120n;FZY:1;
        location = 
Device: uri = smb
        class = network
        info = Windows Printer via SAMBA
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = hp
        class = direct
        info = HP Printer (HPLIP)
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = beh
        class = network
        info = Backend Error Handler
        make-and-model = Unknown
        device-id = 
        location = 
Device: uri = hpfax
        class = direct
        info = HP Fax (HPLIP)
        make-and-model = Unknown
        device-id = 
        location =
Comment 3 Nils Philippsen 2010-08-23 05:21:14 EDT
I could reproduce the "print preview" issue. I'll simply assume that doing an actual print would also show the same symptom. I still try to find out where the problem is, I suspect some changes in the gtk printing subsystem since there are no changes in GIMP code between stable, working versions and Rawhide.
Comment 4 Steven Haigh 2010-09-27 04:40:10 EDT
Are you able to attach an example image that causes this so we can all test on the same base?
Comment 5 Joachim Backes 2010-09-27 05:24:14 EDT
Independent from what I want to print, each document to be printed will be printed as only one page, and that page is empty: gimp-2.6.10-5.fc14.i686.
Nevertheless I will attach such a jpg file.

I will attach the printer properties (System>Administration>Printing>, Clicking on the printer symbol with the right mouse button, saying properties).
Comment 6 Joachim Backes 2010-09-27 05:24:58 EDT
Created attachment 449853 [details]
Printer properties
Comment 7 Joachim Backes 2010-09-27 05:27:20 EDT
Created attachment 449854 [details]
Example document printing an empty page
Comment 8 Steven Haigh 2010-09-27 05:40:15 EDT
Yes, I can confirm this bug. Print preview is a blank page, and that is also what is printed.

$ rpm -qa | grep gimp | sort
gimp-2.6.10-5.fc14.i686
gimp-data-extras-2.0.2-3.fc12.noarch
gimp-help-2.4.2-5.fc12.noarch
gimp-help-browser-2.6.10-5.fc14.i686
gimp-libs-2.6.10-5.fc14.i686
Comment 9 Fedora Update System 2010-10-04 08:05:50 EDT
gimp-2.6.11-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gimp-2.6.11-1.fc14
Comment 10 Nils Philippsen 2010-10-04 09:15:32 EDT
Please try the above update, this fixed the preview problem for me. And don't forget to add karma if it works for you, thanks!
Comment 11 Joachim Backes 2010-10-04 09:43:18 EDT
(In reply to comment #9)
> gimp-2.6.11-1.fc14 has been submitted as an update for Fedora 14.
> https://admin.fedoraproject.org/updates/gimp-2.6.11-1.fc14

Works for me, thank you.
Comment 12 Nils Philippsen 2010-10-04 10:31:25 EDT
Would you please add karma on the update page above so I can push the update to stable early on? Thanks!

I'll let the update mechanism close out the bug once the package has been pushed to stable.
Comment 13 Steven Haigh 2010-10-04 11:53:49 EDT
Works ok for me now too, Karma added.
Comment 14 Fedora Update System 2010-10-04 14:04:45 EDT
gimp-2.6.11-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gimp'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/gimp-2.6.11-1.fc14
Comment 15 Fedora Update System 2010-10-05 09:20:05 EDT
gimp-2.6.11-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Joachim Backes 2010-10-05 11:14:05 EDT
(In reply to comment #12)
> Would you please add karma on the update page above so I can push the update to
> stable early on? Thanks!
> 
> I'll let the update mechanism close out the bug once the package has been
> pushed to stable.

Karma added.
Comment 17 Nils Philippsen 2010-10-05 11:48:49 EDT
(In reply to comment #16)
> Karma added.

I should probably have added "if you have a Fedora account", as anonymously entered karma doesn't get counted. Never mind, some other testers picked this up and it went to stable almost instantly.

Note You need to log in before you can comment on or make changes to this bug.