Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 624419 - fedpkg chain-build foo : doesn't put current package into it's own build group
fedpkg chain-build foo : doesn't put current package into it's own build g...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-packager (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-16 08:01 EDT by Rex Dieter
Modified: 2013-01-10 01:09 EST (History)
3 users (show)

See Also:
Fixed In Version: fedora-packager-0.5.1.4-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-24 17:06:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2010-08-16 08:01:23 EDT
$ rpm -q fedpkg
fedpkg-0.5.1.2-2.fc13.noarch

fedpkg chain-build foo :

doesn't put the current pkg into it's own build group after foo, but tries building in foo's group.


Fwiw, 
fedpkg chain-buid foo : bar
does work to put both the current pkg and bar into a group properly
Comment 1 Jerry James 2010-08-17 10:57:30 EDT
Here's a patch that fixes the issue.

--- fedpkg.orig	2010-08-13 08:18:55.000000000 -0600
+++ fedpkg	2010-08-17 08:48:14.387138421 -0600
@@ -367,10 +367,9 @@
                 log.error('Could not get a build url for %s: %s'
                           % (component, e))
                 sys.exit(1)
-    # Take care of the last build set if we have one
-    if build_set:
-        log.debug('Created a build set: %s' % ' '.join(build_set))
-        urls.append(build_set)
+    # Take care of the last build set
+    log.debug('Created a build set: %s' % ' '.join(build_set))
+    urls.append(build_set)
     # pass it off to build
     args.chain = urls
     args.skip_tag = False

If build_set is nonempty, then we clearly want to append it to urls.

If build_set is empty, due to a trailing ':', then we still want to append it to urls, because the current module is appended to the last element of urls.  By appending the empty build_set, we ensure that the current module will be the only element of that last element; i.e., it is in a group by itself.
Comment 2 Jesse Keating 2010-08-17 19:29:55 EDT
I fixed this, along with a lot of other issues in chain building with http://git.fedorahosted.org/git/?p=fedora-packager.git;a=commit;h=c6c745e8573b8b8df3b9cf673532263608969de1
Comment 3 Fedora Update System 2010-08-24 02:33:49 EDT
fedora-packager-0.5.1.3-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/fedora-packager-0.5.1.3-1.fc14
Comment 4 Fedora Update System 2010-08-24 02:36:10 EDT
fedora-packager-0.5.1.3-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/fedora-packager-0.5.1.3-1.fc13
Comment 5 Fedora Update System 2010-08-24 02:37:52 EDT
fedora-packager-0.5.1.3-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/fedora-packager-0.5.1.3-1.fc12
Comment 6 Fedora Update System 2010-08-24 02:39:51 EDT
fedora-packager-0.5.1.3-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/fedora-packager-0.5.1.3-1.el5
Comment 7 Fedora Update System 2010-08-24 17:05:52 EDT
fedora-packager-0.5.1.3-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2010-09-01 23:58:22 EDT
fedora-packager-0.5.1.4-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2010-09-02 16:33:30 EDT
fedora-packager-0.5.1.4-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2010-09-08 12:28:20 EDT
fedora-packager-0.5.1.4-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.