Bug 62444 - unmounted ext2 dvd-ram file system acts as though it is still mounted
unmounted ext2 dvd-ram file system acts as though it is still mounted
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-31 21:46 EST by Kevin Moore
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-25 16:21:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Moore 2002-03-31 21:46:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)

Description of problem:
When data is written to /mnt/cdrom and then deleted and the file system is 
unmounted, the system reports that the file system is actually mounted and 
displays old information.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
Panasonic DVD-RAM LF-D311SC drive is mounted to /mnt/cdrom. Files are written 
to the media and then deleted or the disk unmounted and reformatted. 


Actual Results:  While the disk is in an unmounted state, do an "ll" command 
on /mnt/cdrom and the system seems to think the file system is actually mounted 
and displays the old contents of the media. I can also write to /mnt/cdrom as 
if it were mounted.


Expected Results:  I would not expect the system to think that a file system 
were mounted when in fact it is not.

Additional info:

Seems a little dangerous that the system may be giving me old data instead of 
what may in fact be on the media that is unmounted.
Comment 1 Elliot Lee 2002-04-15 11:54:37 EDT
Are you sure the filesystem doesn't get mounted twice or something?

Can you give me a shell script to reproduce the problem using loopback mounts?
Comment 2 Kevin Moore 2002-04-25 16:21:07 EDT
File system was not mounted twice. Have since installed the latest Rawhide 
kernel and the problem went away.

Note You need to log in before you can comment on or make changes to this bug.