Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 624449 - PXE provisioning of RHEL6 KVM guest fails on post-install phase
PXE provisioning of RHEL6 KVM guest fails on post-install phase
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
x86_64 Linux
medium Severity high
: rc
: ---
Assigned To: Martin Sivák
Release Test Team
: Patch, Reopened
Depends On:
Blocks: 582655 620463
  Show dependency treegraph
 
Reported: 2010-08-16 10:03 EDT by Garik Khachikyan
Modified: 2015-01-04 16:57 EST (History)
3 users (show)

See Also:
Fixed In Version: anaconda-13.21.77-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-28 11:54:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
3 screenshots of the error (1.26 MB, application/x-gzip)
2010-08-16 10:03 EDT, Garik Khachikyan
no flags Details
Updates image with the fix (8.00 KB, application/octet-stream)
2010-08-16 10:58 EDT, Martin Sivák
no flags Details

  None (edit)
Description Garik Khachikyan 2010-08-16 10:03:32 EDT
Created attachment 438959 [details]
3 screenshots of the error

Description of problem:
---
anaconda fails on post-installation phase with a traceback while doing PXE provisioning of KVM RHEL6 guest (x86_64).
As a RHEL6 channel the current-latest nightly RHEL6 was synced to the Spacewalk 1.1
Traceback looks like (taken the screenshots) - refer to attachments:


Version-Release number of selected component (if applicable):
anaconda-13.21.76-1.el6.x86_64.rpm


How reproducible:
2 of 2 attempts


Steps to Reproduce:
1. Sync to Spacewalk 1.1 RHEL6 x86_64 channel (spacewalk-repo-sync) + nfs mount the latest RHEL6 repodata and use for creating kickstart distribution.
2. make KS profile from that distribution
3. Prepare (if it's not) the Spacewalk to be used as PXE server
4. adjust in dhcpd settings of KVM host (x86_64 RHEL 5.5 for my case) the next_server to be that Spacewalk.
5. PXE provision a RHEL6 x86_64 guest.

  
Actual results:
packages installation ends ok, but on post-installation stage anaconda fails with traceback:


Expected results:
Successfully provisioned RHEL6 guest.


Additional info:
Comment 3 Chris Lumens 2010-08-16 10:15:50 EDT
Martin - this is the stage2 driver disk traceback David mailed you about.
Comment 4 Martin Sivák 2010-08-16 10:28:01 EDT
Already fixed in git, should be available in the next build (anaconda-13.21.75).
Comment 5 Garik Khachikyan 2010-08-16 10:38:41 EDT
(In reply to comment #4)
> Already fixed in git, should be available in the next build
> (anaconda-13.21.75).

Hi Martin, please note that I've found the issue against: anaconda-13.21.76-1.el6.x86_64.rpm (just synced 2 hours before against latest-RHEL6 nfs)
Comment 6 Martin Sivák 2010-08-16 10:56:47 EDT
Sorry I ment anaconda-13.21.77-1. And we just tested the fix with RHEV guys using the latest nightly and updates image.
Comment 7 Martin Sivák 2010-08-16 10:58:01 EDT
Created attachment 438973 [details]
Updates image with the fix
Comment 9 Milan Zázrivec 2010-08-19 04:24:42 EDT
Spacewalk 1.1 has been released.
Comment 10 Garik Khachikyan 2010-08-19 06:22:52 EDT
# COMMENT

The package anaconda-13.21.77-1 fixed my issue with PXE provisioning RHEL6 x86_64 guests.

Hope that the provisioning stuff was/is/would be checking by the RHEL QE teams.

My particular case got resolved: moving the issue to verified.

Note You need to log in before you can comment on or make changes to this bug.