Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 624468 - JSON gem as of version 1.4.6 is causing server errors
JSON gem as of version 1.4.6 is causing server errors
Status: CLOSED CURRENTRELEASE
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-conductor (Show other bugs)
0.3.1
All Mac OS
low Severity medium
: rc
: ---
Assigned To: Hugh Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-16 10:51 EDT by Ladislav Martincik
Modified: 2012-01-26 07:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-01 05:35:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ladislav Martincik 2010-08-16 10:51:32 EDT
Description of problem:
I downloaded deltacloud-core to my directory and tried to run tests for './server/'. I ran 'rake tests'

Version-Release number of selected component (if applicable):
0.0.4

How reproducible:
Install gem json version 1.4.6

Steps to Reproduce:
1. cd server/
2. gem install json --version 1.4.6
3. rake tests
  
Actual results:
Tests failed for:

 test_it_responses_to_json(DeltacloudUnitTest::InstancesTest):
JSON::ParserError: 705: unexpected token at '<h1>Internal Server Error</h1>'

Expected results:
No errors.
Comment 1 Ladislav Martincik 2010-11-01 05:35:16 EDT
Fixed by Ladislav Martincik and posted as: ae2751390f16ed54bb913cbe4106d42a9213be5f by mfojtik
Comment 2 wes hayutin 2011-12-08 08:51:15 EST
perm close

Note You need to log in before you can comment on or make changes to this bug.