Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 624499 - cpufreq_ondemand does not work on atom
cpufreq_ondemand does not work on atom
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
i686 Linux
low Severity medium
: rc
: ---
Assigned To: John Feeney
Red Hat Kernel QE team
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-16 12:51 EDT by Yuji Tsuchimoto
Modified: 2013-01-10 02:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-19 13:19:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yuji Tsuchimoto 2010-08-16 12:51:40 EDT
Description of problem: cpufreq cannot be switched to 'ondemand' but stay on 'performance' at atom machine.


Version-Release number of selected component (if applicable): cpufrequtils-007-4.el6.i686

How reproducible: everytime

Steps to Reproduce:
1. modprobe p4-clockmod
2. modprobe cpufreq_ondemand
3. echo ondemand > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
  
Actual results:
# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
performance


Expected results:
# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
ondemand


Additional info: this patch may help us.
http://www.mail-archive.com/linux-kernel@vger.kernel.org/msg191379.html
Comment 2 RHEL Product and Program Management 2010-08-16 13:18:37 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 RHEL Product and Program Management 2010-08-18 17:23:51 EDT
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Red Hat Enterprise Linux. Unfortunately, we
are unable to address this request in the current release. Because we
are in the final stage of Red Hat Enterprise Linux 6 development, only
significant, release-blocking issues involving serious regressions and
data corruption can be considered.

If you believe this issue meets the release blocking criteria as
defined and communicated to you by your Red Hat Support representative,
please ask your representative to file this issue as a blocker for the
current release. Otherwise, ask that it be evaluated for inclusion in
the next minor release of Red Hat Enterprise Linux.
Comment 4 Yuji Tsuchimoto 2010-08-19 13:04:56 EDT
Thank you for your response.
I am not sure if the RHEL6 would take atom-box into consideration as its target.
In case of 'Yes', the energy efficiency is quite important for atom-box as eco-linux-box, so that cpufreq must work on the box, I believe.

On the other hand, I am afraid the patch I pointed will work fine or not.
I'm not technician and not able to evaluate the patch correctly.
Comment 5 Matthew Garrett 2010-08-19 13:19:28 EDT
p4-clockmod is provided for thermal management purposes only, as it does not support voltage scaling. It will not reduce the energy required to perform a given quantity of work and as such provides no benefit with the ondemand governor. ondemand is only supported on Atom CPUs that provide the Intel Enhanced Speedstep feature.

Note You need to log in before you can comment on or make changes to this bug.