Bug 624500 - "'NoneType' object has no attribute 'length'" exception when trying to install to existing partitions on multipath device
"'NoneType' object has no attribute 'length'" exception when trying to instal...
Status: CLOSED DUPLICATE of bug 624175
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
high Severity high
: rc
: ---
Assigned To: Ales Kozumplik
Release Test Team
:
Depends On: 624505
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-16 13:03 EDT by Jeff Bastian
Modified: 2014-09-30 19:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-19 11:03:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debug patch for anaconda to treat singlepath SCSI devices as multipath device (626 bytes, patch)
2010-08-17 23:23 EDT, Jun'ichi NOMURA
no flags Details | Diff

  None (edit)
Description Jeff Bastian 2010-08-16 13:03:15 EDT
Description of problem:
This is branching from bug 616273 comment 98.  Please see this bug for the
original context.

"'NoneType' object has no attribute 'length'' exception of anaconda when trying to install to existing partitions on multipath device

The same phenomenon has occurred with different operations / conditions.
See the following comment for details:
https://bugzilla.redhat.com/show_bug.cgi?id=616273#c96

The problem was last confirmed with RHEL6 Snapshot10 with the bz616273.img
mentioned in this comment:
https://bugzilla.redhat.com/show_bug.cgi?id=616273#c93


Version-Release number of selected component (if applicable):
anaconda 13.21.68
RHEL 6 Snapshot 10 + bz616273.img


How reproducible:
every time (?)

Steps to Reproduce:
1. Prepare 1 multipath device
2. Create partitions to install RHEL6 from rescue mode
3. Reboot and start RHEL6 installation
4. Select "Specialized Storage Device"
5. Select the multipath device in device selection
6. Select "Create Custom Layout"
7. Put "/" and "/boot" on the existing partitions created in the step 2
8. Click "Next"

Actual results:
anaconda crashes with the error "'NoneType' object has no attribute 'length'"

Expected results:
installation proceeds normally

Additional info:
17:04:27,667 CRITICAL: anaconda 13.21.68 exception report
Traceback (most recent call first):
  File "/tmp/updates/iw/partition_gui.py", line 383, in _createStripe
    / Decimal(str(drive.partedDevice.length)))
  File "/tmp/updates/iw/partition_gui.py", line 302, in setDisplayed
    self.stripe = self._createStripe(obj)
  File "/tmp/updates/iw/partition_gui.py", line 356, in __init__
    self.setDisplayed(drive)
  File "/tmp/updates/iw/partition_gui.py", line 1254, in treeSelectCB
    dcCB = self.barviewActivateCB)
AttributeError: 'NoneType' object has no attribute 'length'
Comment 3 Jun'ichi NOMURA 2010-08-17 23:23:29 EDT
Created attachment 439288 [details]
Debug patch for anaconda to treat singlepath SCSI devices as multipath device

The problem can be reproduced without real multipath hardware
using the attached patch.
Comment 4 Ales Kozumplik 2010-08-18 03:26:52 EDT
Jun'ichi,

can you please try to retest with
updates=http://akozumpl.fedorapeople.org/bz624175.img
in the kernel command line?

The patch ensures multipath parted objects are not torn down when they shouldn't.
Please zip and attach all log files in case of another traceback.

Many thanks.
Ales
Comment 5 Jun'ichi NOMURA 2010-08-18 03:57:19 EDT
With bz624175.img, I got "Invalid Device Specification" as in this BZ:
https://bugzilla.redhat.com/show_bug.cgi?id=624497
Logs uploaded in issuetracker.
Comment 8 Ales Kozumplik 2010-08-19 11:03:01 EDT
Scratch comment 7.

Since the patch from Comment 4 helped get past the point of error, I'm marking this as a dup of 624175.

I'll be tracking progress on the error Jun'ichi is reporting in Comment 5 in bug 624497.

*** This bug has been marked as a duplicate of bug 624175 ***

Note You need to log in before you can comment on or make changes to this bug.