Bug 624511 - Error creating a new user
Error creating a new user
Status: CLOSED DUPLICATE of bug 623969
Product: Pulp
Classification: Community
Component: z_other (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-16 13:55 EDT by Jay Dobies
Modified: 2011-07-15 15:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-17 11:03:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Dobies 2010-08-16 13:55:56 EDT
When running:

[root@guardian ~]# pulp-admin -uadmin -padmin user create --newusername jdob --newpassword foo


The following is output in /var/log/pulp/pulp.log:

2010-08-16 13:51:36,661  password received is foo
2010-08-16 13:51:36,661  login jdob
2010-08-16 13:51:36,661  name 
2010-08-16 13:51:36,671  Traceback (most recent call last):
  File "/home/jdob/vault/code/pulp/src/pulp/webservices/controllers/base.py", line 50, in report_error
    return method(self, *args, **kwargs)
  File "/home/jdob/vault/code/pulp/src/pulp/webservices/role_check.py", line 102, in check_roles
    ret=f(instance, *fargs, **kw)
  File "/home/jdob/vault/code/pulp/src/pulp/webservices/controllers/users.py", line 50, in PUT
    user_data['name'])
  File "/home/jdob/vault/code/pulp/src/pulp/auditing.py", line 186, in _audit
    result = method(*args, **kwargs)
  File "/home/jdob/vault/code/pulp/src/pulp/api/user.py", line 60, in create
    hashed_password = password_util.hash_password(password)
  File "/home/jdob/vault/code/pulp/src/pulp/password_util.py", line 20, in hash_password
    hashed_password = pbkdf_sha256(plain_password, salt, NUM_ITERATIONS)
  File "/home/jdob/vault/code/pulp/src/pulp/password_util.py", line 14, in pbkdf_sha256
    result = HMAC(result, salt, sha256).digest() # use HMAC to apply the salt
  File "/usr/lib64/python2.6/hmac.py", line 72, in __init__
    self.outer.update(key.translate(trans_5C))
TypeError: character mapping must return integer, None or unicode
Comment 1 Pradeep Kilambi 2010-08-17 11:03:14 EDT

*** This bug has been marked as a duplicate of bug 623969 ***

Note You need to log in before you can comment on or make changes to this bug.