Bug 624512 - Password in new user creation should not be displayed on the screen
Password in new user creation should not be displayed on the screen
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: z_other (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Jason Connor
: FutureFeature, Triaged
: 634943 (view as bug list)
Depends On:
Blocks: verified-to-close
  Show dependency treegraph
 
Reported: 2010-08-16 13:58 EDT by Jay Dobies
Modified: 2014-03-30 21:38 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-16 10:20:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Dobies 2010-08-16 13:58:18 EDT
If --newpassword isn't specified, the pulp-admin user should be prompted for the password and not have it echoed on the screen. So the output would look something like:


pulp-admin -uadmin -padmin user create --newusername jdob
Enter new user's password:


And as the password is entered, it's not displayed at the prompt.
Comment 1 Jay Dobies 2010-08-16 14:05:39 EDT
Something else to take into consideration:

<jdob> newpassword isnt a required parameter, is that intentional for some reason?
<mccun934> no
<mccun934> jdob: actually ..  yeah
<jdob> i'm thinking it should be, and if you dont do it on the initial command it prompts you for the non-echoed one
<mccun934> jdob: imagine we were using ldap or some external authentication , could be possible to have no pass
<jdob> hrm, ok, will add that note to the bug
<mccun934> but i think for now we should make it required
<mccun934> since it is broken with out it
Comment 2 Pradeep Kilambi 2010-08-17 11:03:46 EDT
future enhancement
Comment 3 Todd Sanders 2010-09-22 12:01:42 EDT
*** Bug 634943 has been marked as a duplicate of this bug. ***
Comment 4 Sayli Karmarkar 2010-12-03 04:25:35 EST
Fixed. Also as per above comment, password is now 'required'.  

$ sudo pulp-admin user create --username="awesome"
Enter password for user awesome: 
Successfully created user [ awesome ] with name [  ]


I have also made similar changes to "user update". If you pass -P option when updating, it will prompt for new password for the user - 

$ sudo pulp-admin user update --help
Usage: pulp-admin <options> user update <options>

Options:
  -h, --help           show this help message and exit
  --username=USERNAME  username of user you wish to edit. Not editable
                       (required)
  -P, --password       change user password
  --name=NAME          updated name of user for display purposes

$ sudo pulp-admin user update --username="awesome" -P
Enter new password for user awesome: 
Successfully updated [ awesome ] with name [  ]
Comment 5 Jay Dobies 2010-12-03 13:24:18 EST
Fixed in build 0.111.
Comment 6 Preethi Thomas 2010-12-06 16:00:28 EST
verified

[root@10 ~]# rpm -q pulp
pulp-0.0.111-1.fc14.noarch

Last login: Mon Dec  6 13:21:43 2010 from pthomas.rdu.redhat.com
[root@10 ~]# pulp-admin user create --username=life
Enter password for user life: 
Successfully created user [ life ] with name [  ]

[root@10 ~]# pulp-admin user update --username=life --help
Usage: pulp-admin <options> user update <options>

Options:
  -h, --help           show this help message and exit
  --username=USERNAME  username of user you wish to edit. Not editable
                       (required)
  -P, --password       change user password
  --name=NAME          updated name of user for display purposes
[root@10 ~]# pulp-admin user update --username=life -P
Enter new password for user life: 
Successfully updated [ life ] with name [  ]
Comment 7 Preethi Thomas 2011-08-16 10:20:32 EDT
Closing with Community Release 15

pulp-0.0.223-4.

Note You need to log in before you can comment on or make changes to this bug.