Bug 624526 - SELinux is preventing /bin/ps "getattr" access on /etc/rc.d/init.d/shorewall-lite.
SELinux is preventing /bin/ps "getattr" access on /etc/rc.d/init.d/shore...
Status: CLOSED DUPLICATE of bug 624528
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:d1808ad7cdd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-16 14:44 EDT by GJahchan
Modified: 2010-08-17 05:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-17 05:00:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description GJahchan 2010-08-16 14:44:27 EDT
Summary:

SELinux is preventing /bin/ps "getattr" access on
/etc/rc.d/init.d/shorewall-lite.

Detailed Description:

[ps has a permissive type (shorewall_t). This access was not denied.]

SELinux denied access requested by ps. It is not expected that this access is
required by ps and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:shorewall_t:s0
Target Context                system_u:object_r:shorewall_initrc_exec_t:s0
Target Objects                /etc/rc.d/init.d/shorewall-lite [ file ]
Source                        ps
Source Path                   /bin/ps
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           procps-3.2.8-7.fc13
Target RPM Packages           shorewall-lite-4.4.8-1.fc13
Policy RPM                    selinux-policy-3.7.19-28.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.33.5-124.fc13.x86_64 #1 SMP Fri Jun 11
                              09:38:12 UTC 2010 x86_64 x86_64
Alert Count                   3
First Seen                    Fri 11 Jun 2010 10:03:34 PM EEST
Last Seen                     Sat 26 Jun 2010 10:06:53 AM EEST
Local ID                      12698424-c7d1-44a2-827d-b009e2dd468e
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1277536013.503:25275): avc:  denied  { getattr } for  pid=19281 comm="ps" path="/etc/rc.d/init.d/shorewall-lite" dev=dm-1 ino=2231233 scontext=unconfined_u:system_r:shorewall_t:s0 tcontext=system_u:object_r:shorewall_initrc_exec_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1277536013.503:25275): arch=c000003e syscall=4 success=yes exit=4294967424 a0=391ce0ef00 a1=7fff8be6dad0 a2=7fff8be6dad0 a3=fffffffa items=0 ppid=19280 pid=19281 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="ps" exe="/bin/ps" subj=unconfined_u:system_r:shorewall_t:s0 key=(null)



Hash String generated from  catchall,ps,shorewall_t,shorewall_initrc_exec_t,file,getattr
audit2allow suggests:

#============= shorewall_t ==============
allow shorewall_t shorewall_initrc_exec_t:file getattr;
Comment 1 Miroslav Grepl 2010-08-17 05:00:05 EDT

*** This bug has been marked as a duplicate of bug 624528 ***

Note You need to log in before you can comment on or make changes to this bug.