Bug 624544 - initramfs from kernel 2.6.33.6-147.2.4.fc13.i686 fails to boot lvm
Summary: initramfs from kernel 2.6.33.6-147.2.4.fc13.i686 fails to boot lvm
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-16 20:01 UTC by Dennis Schafroth
Modified: 2011-06-28 14:33 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-28 14:33:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
init.log with rddebuginit (47.73 KB, text/plain)
2010-08-16 20:04 UTC, Dennis Schafroth
no flags Details
init.log from a succesful boot (47.73 KB, text/plain)
2010-08-16 20:07 UTC, Dennis Schafroth
no flags Details

Description Dennis Schafroth 2010-08-16 20:01:01 UTC
Description of problem:

The initramfs seems to be missing a step to create the /var/log. This makes /sbin/lvm_scan fail to find the lvm partition. 

Version-Release number of selected component (if applicable):
kernel-2.6.33.6-147.2.4.fc13.i686 (also the PAE)

How reproducible:
Every boot (for me)


Steps to Reproduce:
1. select the kernel version from grub
2. watch dracut to stop  
3.
  
Actual results:
dracut ends in:
"Root device not found"

Expected results:
Same result as the kernel-2.6.33.5-124.fc13.i686; the dracut finds the lvm root partition and boots the system. 

Additional info:
Combining the new kernel with the older initramfs actually booted the system! 

Regenerated dracut for the kernel did not boot either.

Comment 1 Dennis Schafroth 2010-08-16 20:04:39 UTC
Created attachment 439011 [details]
init.log with rddebuginit

From the failed boot

Comment 2 Dennis Schafroth 2010-08-16 20:07:39 UTC
Created attachment 439012 [details]
init.log from a succesful boot

From successful boot

Comment 3 Chuck Ebbert 2010-08-17 01:48:10 UTC
Pretty sure this is an lvm problem caused by updating lvm and the kernel at the same time. Did you try recreating the initrd?

  /sbin/new-kernel-pkg --package kernel --mkinitrd --dracut --depmod --update kernel-2.6.33.6-147.2.4.fc13.i686

(The above command all on one line.)

Comment 4 Dennis Schafroth 2010-08-17 05:55:48 UTC
I did (dracut <initramfs> <kernelversion>), but not in your way. 

Did:

/sbin/new-kernel-pkg --package kernel --mkinitrd --dracut --depmod --update 2.6.33.6-147.2.4.fc13.i686

checked that the initramfs was regenerated:
# ls -la /boot/initramfs-2.6.33.6-147.2.4.fc13.i686.img 
-rw-r--r--. 1 root root 11925278 Aug 17 07:36 /boot/initramfs-2.6.33.6-147.2.4.fc13.i686.img

checked the grub entry:
title Fedora (2.6.33.6-147.2.4.fc13.i686)
	root (hd0,0)
	kernel /vmlinuz-2.6.33.6-147.2.4.fc13.i686 ro root=/dev/mapper/VolGroup-lv_root  LANG=en_DK.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=dk rdshell rdinitdebug
	initrd /initramfs-2.6.33.6-147.2.4.fc13.i686.img

(back to the new initramfs)

and booted this entry. This fails again and ends in the dracut shell. 

Forgot to get the log, but it looked similar, can get it after work today, if required.

Comment 5 Chuck Ebbert 2010-08-17 10:52:17 UTC
There's no difference between the logs from the failure and working case.

> The initramfs seems to be missing a step to create the /var/log. This makes
> /sbin/lvm_scan fail to find the lvm partition. 

What does that mean exactly?

Comment 6 Dennis Schafroth 2010-08-17 12:09:17 UTC
(In reply to comment #5)
> There's no difference between the logs from the failure and working case.

That's strange. When I compare them there are some differences. But maybe not enough. 

What else would you like to get?  

> 
> > The initramfs seems to be missing a step to create the /var/log. This makes
> > /sbin/lvm_scan fail to find the lvm partition. 
> 
> What does that mean exactly?

well, manybe I was jumping into conclusions too fast. 

Both boots complains about the missing /var/log but only the newer fails to find root device. 

In the dracut shell, I tried manually to run the /sbin/lvm_scan and the output is different if I have made the /var/log directory. Thus my (perhaps wrongly) conclusion was that this directory was required.

Comment 7 Bug Zapper 2011-06-01 11:24:08 UTC
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 8 Bug Zapper 2011-06-28 14:33:38 UTC
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.