Bug 624568 - Anaconda error - no usable disks present
Anaconda error - no usable disks present
Status: CLOSED DUPLICATE of bug 622551
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
i386 Linux
low Severity high
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-16 21:34 EDT by cartmancakes
Modified: 2010-08-17 13:04 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-17 12:11:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (135.15 KB, image/jpeg)
2010-08-16 21:34 EDT, cartmancakes
no flags Details
anaconda log (4.55 KB, application/octet-stream)
2010-08-16 21:36 EDT, cartmancakes
no flags Details
storage log (31.75 KB, application/octet-stream)
2010-08-16 21:38 EDT, cartmancakes
no flags Details

  None (edit)
Description cartmancakes 2010-08-16 21:34:51 EDT
Created attachment 439040 [details]
screenshot

Description of problem:
When installing RHEL6-snapshot10, at the time when you select a disk for installation, when I select a multipath device, I get the message, "no usable disks have been found".  This is an HP blade system, connected through an Emulex Mezz card (I've tried both LP1105 and a converged network adapter).  I've tried it through a Brocade and a QLogic fabric.  I've also changed storage arrays.  I've tried an EVA6400 and an XP20000.  I've also tried both i386 and x64 flavors of RHEL6.  I've also tried doing a dd of dev/zero to the boot LUN I'm trying to use.  All of these produce the same results.  However, if there's only one path, there is no problem.

Version-Release number of selected component (if applicable):
I'm not sure what the release version numbers are with Snapshot-10

How reproducible:
For me, this happens every time.

Steps to Reproduce:
1. begin install of RHEL6 Snapshot10
2. choose a multipath device to install the OS to.
3.
  
Actual results:
Message "No usable disks have been found"

Expected results:
I expected the disk to be able to be used for installing the OS.

Additional info:
Comment 1 cartmancakes 2010-08-16 21:36:53 EDT
Created attachment 439041 [details]
anaconda log
Comment 2 cartmancakes 2010-08-16 21:38:13 EDT
Created attachment 439043 [details]
storage log

In this log, I'm noticing some lines where it's ignoring ALL of the multipathed devices.
Comment 4 RHEL Product and Program Management 2010-08-16 21:58:32 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 5 David Cantrell 2010-08-17 12:11:32 EDT

*** This bug has been marked as a duplicate of bug 622551 ***
Comment 6 cartmancakes 2010-08-17 12:37:53 EDT
I do not have access to that bug report.  Can you grant it?  Or give me status on the issue?

Thanks!
Comment 7 Chris Lumens 2010-08-17 13:04:44 EDT
A potential fix for this issue is in anaconda-13.21.74-1 and is currently being tested.  If all goes well, it'll be fixed in RHEL6 GA,

Note You need to log in before you can comment on or make changes to this bug.