Bug 62461 - (Mozilla) CTRL-A doesn't Select-All in textfields
(Mozilla) CTRL-A doesn't Select-All in textfields
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: mozilla (Show other bugs)
skipjack-beta1
All Linux
medium Severity low
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-01 04:22 EST by Warren Togami
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-01 07:47:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2002-04-01 04:22:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461; .NET 
CLR 1.0.3705)

Description of problem:
CTRL-A doesn't Select-All in textfields, textareas and URL bar.  Instead it 
jumps to the beginning of the line.

This may be a Mozilla regression since a similar fixed bug in Mozilla 0.9.2.
http://bugzilla.mozilla.org/show_bug.cgi?id=74643

I posted the following to that bug report:

In both build 200231416 (Red Hat Skipjack beta) and 2002032808 (nightly Linux) 
Accel-A no longer Selects-All.  Instead, it makes the cursor jump to the 
beginning of the line in the URL bar, textfield or textarea.

Ok, I now realize that Linux Netscape 4.7x behaves like this too, and CTRL-A is 
the Emacs keybinding to go to the beginning of the line.  My friend said 
that "This isn't a bug because that is the behavior of GTK+, and maybe some 
people LIKE the Emacs-like keybinding."

I like Emacs, but in this case I don't like this behavior and I rather expect 
it to behave identically to Windows Mozilla (and Konqueror, Opera, Internet 
Explorer...)

Mozilla's own menu says that CTRL-A is a shortcut for Select-All, so I expect 
that it would work in a textfield.  It doesn't make logical sense to instead 
jump to the beginning of the line.


Version-Release number of selected component (if applicable):
Skipjack-beta1 with up2date (3-27-2002)

How reproducible:
Always
Comment 1 Pawel Salek 2002-04-01 07:47:50 EST
Ctrl-A has different meanings depending whether a text field is selected or not.

Ctrl-A moves the cursor to the beginning of th line when a text field is
selected (and it should stay this way, IMO).

Ctrl-A - Select all text on the page otherwise.
Comment 2 Christopher Blizzard 2002-04-01 18:06:32 EST
That's not a bug.

Note You need to log in before you can comment on or make changes to this bug.