Bug 624621 - [radeon] X crashes on ATI Radeon X800 SE (R430) when unlocking OpenGL screensaver
[radeon] X crashes on ATI Radeon X800 SE (R430) when unlocking OpenGL screens...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jérôme Glisse
Fedora Extras Quality Assurance
: Reopened, Triaged
: 666593 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-17 05:37 EDT by Joachim Frieben
Modified: 2018-04-11 10:31 EDT (History)
8 users (show)

See Also:
Fixed In Version: xorg-x11-drv-ati-6.13.1-0.4.20100705git37b348059.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-05 08:17:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log of ATI Radeon X800 SE (R430) with a trailing backtrace (129.75 KB, text/plain)
2010-08-17 05:37 EDT, Joachim Frieben
no flags Details
Xorg.0.log of ATI Radeon X800 SE (R430) with a trailing backtrace (145.37 KB, text/plain)
2010-10-14 14:25 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2010-08-17 05:37:58 EDT
Created attachment 439076 [details]
Xorg.0.log of ATI Radeon X800 SE (R430) with a trailing backtrace

Description of problem:
After entering the user password to unlock some OpenGL based screen saver from a running GNOME session, X aborts, and the user is dropped to the GNOME login manager.
Xorg.0.log shows a trailing backtrace indicating a segmentation fault causing the X server to abort.

Backtrace:
[   751.376] 0: /usr/bin/Xorg (xorg_backtrace+0x28) [0x49ffa8]
[   751.376] 1: /usr/bin/Xorg (0x400000+0x60a89) [0x460a89]
[   751.376] 2: /lib64/libc.so.6 (0x3d3f200000+0x33f80) [0x3d3f233f80]
[   751.377] 3: /usr/lib64/xorg/modules/libexa.so (exaGetPixmapDriverPrivate+0x24) [0x7f4746f084d4]
[   751.377] 4: /usr/lib64/xorg/modules/drivers/radeon_drv.so (0x7f4747546000+0xca40f) [0x7f474761040f]
[   751.377] 5: /usr/lib64/xorg/modules/drivers/radeon_drv.so (0x7f4747546000+0xcad93) [0x7f4747610d93]
[   751.377] 6: /usr/lib64/libdrm.so.2 (drmHandleEvent+0x103) [0x3d4ba065f3]
[   751.377] 7: /usr/bin/Xorg (WakeupHandler+0x4b) [0x43157b]
[   751.377] 8: /usr/bin/Xorg (WaitForSomething+0x1a4) [0x459e34]
[   751.377] 9: /usr/bin/Xorg (0x400000+0x2d1b2) [0x42d1b2]
[   751.377] 10: /usr/bin/Xorg (0x400000+0x2148e) [0x42148e]
[   751.378] 11: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x3d3f21ecfd]
[   751.378] 12: /usr/bin/Xorg (0x400000+0x21039) [0x421039]
[   751.378] Segmentation fault at address 0x2000000078
[   751.378]
Fatal server error:
[   751.378] Caught signal 11 (Segmentation fault). Server aborting

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.13.1-0.2.20100705git37b348059.fc14.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Choose OpenGL based screensaver.
2. Lock display.
3. Unlock display.

Actual results:
X aborts.

Expected results:
Display gets unlocked and user can resume the running GNOME session.

Additional info:
None.
Comment 1 Joachim Frieben 2010-08-17 09:32:03 EDT
Actually, certain screensavers are more prone of triggering said crash. In particular, those of package rss-glx-0.9.1.p-3.fc14.x86_64 are whereas modules like "Juggler3D" or "Hanoi" appear to be insensitive to this issue. However, module "Menger" also happened once to make X abort even though it is part of package xscreensaver-gl-extras-5.11-8.1.fc14.respin1.x86_64.
Comment 2 Joachim Frieben 2010-09-24 03:42:55 EDT
Fixed in xorg-x11-drv-ati-6.13.1-0.4.20100705git37b348059.fc14.x86_64:
* Fri Aug 27 2010 Dave Airlie <airlied@...> 6.13.1-0.4.20100705git37b348059
- fix dri2 pixmap refcounting bug
Comment 3 Matěj Cepl 2010-09-24 12:54:00 EDT
Thank you for letting us know.
Comment 4 Joachim Frieben 2010-10-14 14:25:36 EDT
Created attachment 453528 [details]
Xorg.0.log of ATI Radeon X800 SE (R430) with a trailing backtrace

For a fully updated F14, the issue is not completely gone, even though it is harder to trigger than when the original report was posted. X still crashes when opening screensaver preferences and alternating between two GL screensaver modules repeatedly. After several changes at most, X will crash, and the user is dropped to the graphical login manager. The traceback in Xorg.0.log is essentially identical to the original one. Installed packages include:
- kernel-2.6.35.6-42.fc14.x86_64
- libdrm-2.4.22-1.fc14.x86_64
- mesa-libGL-7.9-1.fc14.x86_64
- mesa-libGLU-7.9-1.fc14.x86_64
- xorg-x11-drv-ati-6.13.1-0.3.20100705git37b348059.fc14.x86_64
- xorg-x11-server-Xorg-1.9.0-15.fc14.x86_64
Comment 5 Joachim Frieben 2010-10-14 14:34:41 EDT
It appears that the issue is fully gone after retrieving xorg-x11-drv-ati-6.13.1-0.4.20100705git37b348059.fc14.x86_64 from Koji as I had already reported three weeks ago in comment 2. It would be a good idea to actually push the latest build to F14 testing updates before the release.
Comment 6 Joachim Frieben 2010-12-01 01:02:47 EST
Fixed package version 0.4.20100705git37b348059.fc14 still does not get installed on a new F14 system including updates.
Comment 7 Matěj Cepl 2010-12-07 08:05:24 EST
(In reply to comment #6)
> Fixed package version 0.4.20100705git37b348059.fc14 still does not get
> installed on a new F14 system including updates.

Dave, reporter is right ... did you push the package to Bodhi?
Comment 8 Joachim Frieben 2011-01-10 03:33:16 EST
Fixed package version 0.4.20100705git37b348059.fc14 still does not get
installed on a new F14 system including updates and updates-testing.
Comment 9 Ian Pilcher 2011-01-24 18:32:17 EST
xorg-x11-drv-ati-6.13.1-0.4.20100705git37b348059.fc14.x86_64 fixes my crashes as well.
Comment 10 Fedora Update System 2011-01-31 18:52:03 EST
xorg-x11-drv-ati-6.13.1-0.4.20100705git37b348059.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xorg-x11-drv-ati-6.13.1-0.4.20100705git37b348059.fc14
Comment 11 Fedora Update System 2011-02-01 15:53:20 EST
xorg-x11-drv-ati-6.13.1-0.4.20100705git37b348059.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-ati'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/xorg-x11-drv-ati-6.13.1-0.4.20100705git37b348059.fc14
Comment 12 Joachim Frieben 2011-03-02 09:44:40 EST
xorg-x11-drv-ati-6.13.1-0.4.20100705git37b348059.fc14 is still in the
Fedora 14 testing repository. However, bug 677037 associated with the only negative feedback has been closed as CANTFIX because it is related to some Flash issue which cannot be investigated. Moreover, I cannot reproduce it on similar hardware using the latest 64 bit release of the Flash plugin.
Comment 13 Fedora Update System 2011-03-03 03:40:58 EST
xorg-x11-drv-ati-6.13.1-0.4.20100705git37b348059.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Stan Trzmiel 2011-03-17 10:26:52 EDT
*** Bug 666593 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.