Bug 624656 - GeometryException: must specify PedGeometry or (device, start, length) or (device, start, end) or (device, start, length, end)
GeometryException: must specify PedGeometry or (device, start, length) or (de...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: David Lehman
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-17 07:58 EDT by Jan Stodola
Modified: 2010-11-19 15:52 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-19 15:52:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2010-08-17 07:58:34 EDT
Description of problem:

anaconda 13.21.74 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/geometry.py", line 61, in __init__
    raise parted.GeometryException, "must specify PedGeometry or (device, start, length) or (device, start, end) or (device, start, length, end)"
  File "/usr/lib64/python2.6/site-packages/parted/decorators.py", line 31, in localeC
    ret = fn(*args, **kwds)
  File "<string>", line 2, in __init__
  File "/usr/lib/anaconda/storage/partitioning.py", line 1579, in growPartitions
    end=end)
  File "/usr/lib/anaconda/storage/partitioning.py", line 869, in doPartitioning
    growPartitions(disks, partitions, free)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1584, in refresh
    doPartitioning(self.storage)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1683, in editPartition
    if self.refresh(justRedraw=not actions):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1558, in createCB
    self.editPartition(device, isNew = True)
GeometryException: must specify PedGeometry or (device, start, length) or (device, start, end) or (device, start, length, end)

Version-Release number of selected component (if applicable):
RHEL6.0-20100811.2
anaconda-13.21.74-1.el6

How reproducible:
always

Steps to Reproduce:
1. prepare a sparse file, size about 5TB:
dd if=/dev/zero of=images/5T bs=1M count=1 seek=5000000
2. run RHEL6 installation in KVM use the sparse file as a disk
3. Use custom partitioning and create:
 *  /     ext4  "Fill to maximum allowable size"
 *  /usr  ext4  "Fixed size": 2097151 MB
  
Actual results:
Anaconda creates 2097151 MB partition for /
Traceback when attempting to create second partition for /usr with fixed size.

Expected results:
no traceback after adding second partition

Additional info:
Comment 2 David Lehman 2010-11-19 15:52:10 EST
This is happening because you are installing on a BIOS system, therefore anaconda creates an msdos partition table. If you want to be able to use the whole disk, create a gpt disklabel on it before you start anaconda.

Note You need to log in before you can comment on or make changes to this bug.