Bug 624669 - dead keys doesn't work in X11 emacs when run within tmux
dead keys doesn't work in X11 emacs when run within tmux
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: tmux (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Filipe Rosset
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-17 09:04 EDT by Honza 'thingie' Bartoš
Modified: 2011-06-28 10:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-28 10:33:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tmux output (12.65 KB, text/x-log)
2011-01-06 00:01 EST, Honza 'thingie' Bartoš
no flags Details

  None (edit)
Description Honza 'thingie' Bartoš 2010-08-17 09:04:21 EDT
Description of problem:
When I run emacs (GTK+ interface, either as daemon and emacsclient -c or just emacs) within tmux, with any locale or settings I know about, dead keys doesn't work there, producing just errors like "<dead-acute> is undefined". This problem doesn't happen in any other settings (with screen, just ordinary vt, …), but I don't know what tmux does that make this happen. Console emacs (emacs -nw) works just fine.


Version-Release number of selected component (if applicable):
emacs-23.2-4.fc13.i686
tmux-1.2-1.fc13.i686

How reproducible:
Run tmux, emacs in it, try to use some dead keys.
Comment 1 Filipe Rosset 2011-01-05 07:55:12 EST
Does it happen with tmux 1.4 or CVS HEAD?

If so, then kill tmux, run tmux -vvvv, hit a few dead keys, kill tmux and paste the logs here.
Comment 2 Honza 'thingie' Bartoš 2011-01-06 00:01:35 EST
Created attachment 471986 [details]
tmux output

I got this, but I'm not sure if it makes any sense. In fact, while I'm sure that I was able to reproduce this back then, now, i'm back to the behavior where dead keys within emacs doesn't work at all, no matter what (except emacs -nw). I've even tried to compile my own emacs with lucid toolkit instead of gtk.

Of course, the main difference is that I've upgraded to f14 since. I don't have any f13 machine left to try it there.
Comment 3 NM 2011-01-13 15:41:13 EST
Show me the output of "tmux info" with tmux running, and "env" inside and outside tmux please.
Comment 5 NM 2011-01-13 16:17:55 EST
If you run emacs with "TERM=xterm emacs" inside tmux does it work?
Comment 6 Bug Zapper 2011-06-01 07:23:09 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2011-06-28 10:33:08 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.