Bug 624716 - luci displays misleading error status on initial cluster configuration pages
Summary: luci displays misleading error status on initial cluster configuration pages
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Ryan McCabe
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-17 14:52 UTC by Steven J. Levine
Modified: 2016-04-26 14:28 UTC (History)
3 users (show)

Fixed In Version: luci-0.23.0-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 13:56:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0655 normal SHIPPED_LIVE luci bug fix update 2011-05-19 09:47:45 UTC

Description Steven J. Levine 2010-08-17 14:52:14 UTC
Description of problem:

When I first go to some of the component configuration pages, before I have configured anything, luci displays this error message (which is not true):

No nodes from this cluster could be contacted. The status of this cluster is unknown. 

This appears for the intial Services, Resources, Failover Domains,and Fence Devices configuration pages. I have enclosed an attachment showing the initial Fence Devices page.

Once I configure anything, however, the display shows what I have configured and that error message is gone. (This is why it does not appear for the "Configure" page, I believe, since in that case the initial screen already shows a general properties display.)

However -- if, for example, I add a fence device then delete that fence device, the "No nodes could be contacted" error message appears again.

In short: It appears as if luci has nothing to display for any of these pages, by default it displays the the "No nodes from this cluster" error message.


Version-Release number of selected component (if applicable):

I am running luci version is luci-0.22.2-13.el6.x86_6

Comment 3 Steven J. Levine 2010-11-29 19:59:23 UTC
I'm not sure I understand the question in Comment 2 -- The error message displayed has no effect on operation, it just seems to be a default display if there's nothing configured to display, but it doesn't prevent configuration.

Comment 10 errata-xmlrpc 2011-05-19 13:56:22 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0655.html


Note You need to log in before you can comment on or make changes to this bug.