Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 624724 - Missing /usr/share/rhn/server/handlers directory
Missing /usr/share/rhn/server/handlers directory
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
540
All Linux
high Severity high
: ---
: ---
Assigned To: Shannon Hughes
Garik Khachikyan
:
Depends On:
Blocks: sat540-blockers 625353
  Show dependency treegraph
 
Reported: 2010-08-17 11:20 EDT by Garik Khachikyan
Modified: 2015-01-04 16:57 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 625353 (view as bug list)
Environment:
Last Closed: 2010-10-28 10:46:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dependency issue - simple-core (7.18 KB, application/octet-stream)
2010-08-18 04:30 EDT, Garik Khachikyan
no flags Details
/var/spool/mail/root (29.41 KB, text/plain)
2010-08-18 05:40 EDT, Šimon Lukašík
no flags Details

  None (edit)
Description Garik Khachikyan 2010-08-17 11:20:01 EDT
Description of problem:
After installation of the Satellite 540 from iso: Satellite-5.4.0-RHEL5-re20100817.0-x86_64.iso the error log of httpd complains about absence of:
"/usr/share/rhn/server/handlers" directory
There seems that spacewalk-backend* packages are responsible for the files under that directory.
And the versions of SW 1.1 and Sat 5.4 are different.

Version-Release number of selected component (if applicable):
Satellite-5.4.0-RHEL5-re20100817.0-x86_64.iso
== SW 1.1 rpm versions ==
spacewalk-backend-sql-oracle-1.1.42-1.el5
spacewalk-backend-1.1.42-1.el5
spacewalk-backend-config-files-common-1.1.42-1.el5
spacewalk-backend-package-push-server-1.1.42-1.el5
spacewalk-backend-libs-1.1.42-1.el5
spacewalk-backend-sql-1.1.42-1.el5
spacewalk-backend-xml-export-libs-1.1.42-1.el5
spacewalk-backend-xmlrpc-1.1.42-1.el5
spacewalk-backend-tools-1.1.42-1.el5
spacewalk-backend-config-files-tool-1.1.42-1.el5
spacewalk-backend-iss-export-1.1.42-1.el5
spacewalk-backend-applet-1.1.42-1.el5
spacewalk-backend-xp-1.1.42-1.el5
spacewalk-backend-server-1.1.42-1.el5
spacewalk-backend-app-1.1.42-1.el5
spacewalk-backend-config-files-1.1.42-1.el5
spacewalk-backend-iss-1.1.42-1.el5

== Sat 5.4 rpm versions ==
spacewalk-backend-sql-oracle-1.2.3-1.el5sat
spacewalk-backend-xml-export-libs-1.2.3-1.el5sat
spacewalk-backend-iss-export-1.2.3-1.el5sat
spacewalk-backend-package-push-server-1.2.3-1.el5sat
spacewalk-backend-1.2.3-1.el5sat
spacewalk-backend-sql-1.2.3-1.el5sat
spacewalk-backend-config-files-common-1.2.3-1.el5sat
spacewalk-backend-app-1.2.3-1.el5sat
spacewalk-backend-config-files-tool-1.2.3-1.el5sat
spacewalk-backend-iss-1.2.3-1.el5sat
spacewalk-backend-xp-1.2.3-1.el5sat
spacewalk-backend-upload-server-1.2.3-1.el5sat
spacewalk-backend-tools-1.2.3-1.el5sat
spacewalk-backend-libs-1.2.3-1.el5sat
spacewalk-backend-server-1.2.3-1.el5sat
spacewalk-backend-xmlrpc-1.2.3-1.el5sat
spacewalk-backend-config-files-1.2.3-1.el5sat
spacewalk-backend-applet-1.2.3-1.el5sat


How reproducible:
Always on calling rhnpush

Steps to Reproduce:
1. make rhnpush simple actions.
2. Look at /var/log/httpd/error_log
3.
  
Actual results:
rhnpush functionality is blocked

Expected results:
Directory should be present (with all the structure there). rhnpush should work,

Additional info:
It's kinda blocker and needs to be fixed asap
Comment 2 Garik Khachikyan 2010-08-18 04:30:15 EDT
after checking the re-spined ISO Satellite-5.4.0-RHEL5-re20100817.1-x86_64.iso there appeared another error preventing its installation at all:
---
simple-core is needed by spacewalk-java-1.2.6-1.el5sat.noarch

So please add it as well. thx.
Attached is the log of rhn-installation.log
Comment 3 Garik Khachikyan 2010-08-18 04:30:47 EDT
Created attachment 439320 [details]
dependency issue - simple-core
Comment 4 Garik Khachikyan 2010-08-18 04:34:17 EDT
err: my fault. Needed to manually remove the simple-core.
(was running on already installed version)
Comment 5 Garik Khachikyan 2010-08-18 04:45:54 EDT
fixed.
Comment 6 Milan Zázrivec 2010-08-18 05:28:34 EDT
This problem is fixed in spacewalk-backend-1.2.4-1.

Reassigning to Miroslav Suchy (who's responsible for the change) and
also changing the component from installer to server (since this bug
is not even remotely related to the sat. installer).
Comment 7 Šimon Lukašík 2010-08-18 05:39:26 EDT
On new compose Satellite-5.4.0-RHEL5-re20100817.1 we still cannot rhnpush packages to server, although simptoms are different now.

rhnpush ends up with "Internal Server Error" for very simple uses. Packages are uploaded to server but not assiciated to the channel.


rhnpush output:
Connecting to https://dell-pem605-01.rhts.eng.bos.redhat.com/APP
Package /tmp/packages-L28345/test-regular-test-i386-0-1282121817-0.2-2.i386.rpm Not Found on RHN Server -- Uploading
Uploading package /tmp/packages-L28345/test-regular-test-i386-0-1282121817-0.2-2.i386.rpm
Using POST request
Package /tmp/packages-L28345/test-exclude-test-i386-0-1282121817-0.2-2.i386.rpm Not Found on RHN Server -- Uploading
Uploading package /tmp/packages-L28345/test-exclude-test-i386-0-1282121817-0.2-2.i386.rpm
Using POST request
Package /tmp/packages-L28345/test-regular-test-i386-0-1282121817-0.1-1.i386.rpm Not Found on RHN Server -- Uploading
Uploading package /tmp/packages-L28345/test-regular-test-i386-0-1282121817-0.1-1.i386.rpm
Using POST request
Package /tmp/packages-L28345/test-obsoleted-test-i386-0-1282121817-0.1-1.i386.rpm Not Found on RHN Server -- Uploading
Uploading package /tmp/packages-L28345/test-obsoleted-test-i386-0-1282121817-0.1-1.i386.rpm
Using POST request
Package /tmp/packages-L28345/somepackage-test-i386-0-1282121817-0.2-2.i386.rpm Not Found on RHN Server -- Uploading
Uploading package /tmp/packages-L28345/somepackage-test-i386-0-1282121817-0.2-2.i386.rpm
Using POST request
Package /tmp/packages-L28345/test-only-new-test-i386-0-1282121817-0.2-2.i386.rpm Not Found on RHN Server -- Uploading
Uploading package /tmp/packages-L28345/test-only-new-test-i386-0-1282121817-0.2-2.i386.rpm
Using POST request
Package /tmp/packages-L28345/test-exclude-test-i386-0-1282121817-0.1-1.i386.rpm Not Found on RHN Server -- Uploading
Uploading package /tmp/packages-L28345/test-exclude-test-i386-0-1282121817-0.1-1.i386.rpm
Using POST request
Package /tmp/packages-L28345/test-obsoletes-test-i386-0-1282121817-0.1-1.i386.rpm Not Found on RHN Server -- Uploading
Uploading package /tmp/packages-L28345/test-obsoletes-test-i386-0-1282121817-0.1-1.i386.rpm
Using POST request
Package /tmp/packages-L28345/somepackage-test-i386-0-1282121817-0.1-1.i386.rpm Not Found on RHN Server -- Uploading
Uploading package /tmp/packages-L28345/somepackage-test-i386-0-1282121817-0.1-1.i386.rpm
Using POST request
Internal Server Error
:: [   FAIL   ] :: Running 'runcon  -u root -r system_r -t unconfined_t -l s0 -- rhnpush --channel=test-i386-0 --dir=/tmp/packages-L28345 --nosig --username=admin --password=admin -v --server=https://dell-pem605-01.rhts.eng.bos.redhat.com/APP' (Expected 0, got 255)
Comment 8 Šimon Lukašík 2010-08-18 05:40:15 EDT
Created attachment 439342 [details]
/var/spool/mail/root
Comment 9 Garik Khachikyan 2010-08-18 05:53:55 EDT
and also seems they are uploading to Satellite server but not get linked to the channel specified there.
Comment 11 Garik Khachikyan 2010-08-20 06:20:13 EDT
checked the issues with directory presence as well as functionality for rhnpush.

all are fine with the recent iso: Satellite-5.4.0-RHEL5-re20100818.0-x86_64.iso

@devel: please shift the bug to the proper state for QE to verify it. thx
Comment 13 Garik Khachikyan 2010-08-24 10:57:04 EDT
# VERIFIED

So, here is the ISO fixing the problems there: Satellite-5.4.0-RHEL5-re20100820.0-x86_64.iso
Comment 15 Miroslav Suchý 2010-10-22 06:08:21 EDT
[root@tyan-gt24-03 ~]# ls -ld /usr/share/rhn/server/handlers
drwxr-xr-x 9 root root 4096 Oct 18 09:56 /usr/share/rhn/server/handlers
Comment 16 Clifford Perry 2010-10-28 10:42:23 EDT
The 5.4.0 RHN Satellite and RHN Proxy release has occurred. This issue has been resolved with this release. 


RHEA-2010:0801 - RHN Satellite Server 5.4.0 Upgrade
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10332

RHEA-2010:0803 - RHN Tools enhancement update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10333

RHEA-2010:0802 - RHN Proxy Server 5.4.0 bug fix update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10334

RHEA-2010:0800 - RHN Satellite Server 5.4.0
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10335

Docs are available:

http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/index.html 

Regards,
Clifford

Note You need to log in before you can comment on or make changes to this bug.