Bug 62475 - FTP hangs if the response to "QUIT" command gets lost for the first time
FTP hangs if the response to "QUIT" command gets lost for the first time
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ftp (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-01 08:42 EST by Need Real Name
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-13 05:19:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tcpdump traces for the FTP scenario right from the begining of FTP till the hang. (790.19 KB, patch)
2002-04-01 09:57 EST, Need Real Name
no flags Details | Diff

  None (edit)
Description Need Real Name 2002-04-01 08:42:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (WinNT; U)

Description of problem:
FTP file transfer occurs successfully. After that a "QUIT" command is send from the client.
The response to this command is somehow lost. The TCP ack mechanism takes care of retransmission.
However, the client does not accept this retransmitted response.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Initiate a file transfer through ftp (either get or put)
2.After file transfer is complete give a "bye" command. But somehow block the response coming from the server (do not know how exactly to do this)
3.Unblock the path again between the client and the server so that the client gets the retransmitted response.
	

Actual Results:  The client side FTP is in a hanged state

Expected Results:  The client should accept the response from the server everytime, whether or not it comes through retransmission.

Additional info:

Below the IP layer we have a GPRS stack. It is quite likely to have occasional data loss and thus we arrived at the
problem scenario.
Comment 1 Need Real Name 2002-04-01 09:57:50 EST
Created attachment 51646 [details]
tcpdump traces for the FTP scenario right from the begining of FTP till the hang.
Comment 2 Thomas Woerner 2004-08-13 05:19:34 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or Fedora
Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.

Note You need to log in before you can comment on or make changes to this bug.