Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 624763 - SELinux is preventing /bin/bash "getattr" access on /sbin/ldconfig.
SELinux is preventing /bin/bash "getattr" access on /sbin/ldconfig.
Status: CLOSED DUPLICATE of bug 625910
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
14
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:b3fb02411f6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-17 13:03 EDT by Christian Joensson
Modified: 2010-09-07 20:27 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-23 11:32:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Joensson 2010-08-17 13:03:12 EDT
Summary:

SELinux is preventing /bin/bash "getattr" access on /sbin/ldconfig.

Detailed Description:

SELinux denied access requested by sh. It is not expected that this access is
required by sh and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:unconfined_r:telepathy_msn_t:s0-s0:c0
                              .c1023
Target Context                system_u:object_r:ldconfig_exec_t:s0
Target Objects                /sbin/ldconfig [ file ]
Source                        sh
Source Path                   /bin/bash
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           bash-4.1.7-3.fc14
Target RPM Packages           glibc-2.12.90-7
Policy RPM                    selinux-policy-3.8.8-14.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.35-3.fc14.i686.PAE #1 SMP
                              Fri Aug 6 19:41:17 UTC 2010 i686 i686
Alert Count                   18
First Seen                    Mon 16 Aug 2010 07:02:16 PM CEST
Last Seen                     Tue 17 Aug 2010 07:00:02 PM CEST
Local ID                      e734c8b3-741a-4b97-8338-45cd800028b6
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1282064402.908:46): avc:  denied  { getattr } for  pid=2544 comm="sh" path="/sbin/ldconfig" dev=dm-0 ino=2752785 scontext=unconfined_u:unconfined_r:telepathy_msn_t:s0-s0:c0.c1023 tcontext=system_u:object_r:ldconfig_exec_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1282064402.908:46): arch=40000003 syscall=195 success=no exit=-13 a0=9c9f170 a1=bff7bbd0 a2=b28ff4 a3=9c9f170 items=0 ppid=2543 pid=2544 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="sh" exe="/bin/bash" subj=unconfined_u:unconfined_r:telepathy_msn_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,sh,telepathy_msn_t,ldconfig_exec_t,file,getattr
audit2allow suggests:

#============= telepathy_msn_t ==============
allow telepathy_msn_t ldconfig_exec_t:file getattr;
Comment 1 Daniel Walsh 2010-08-23 11:32:27 EDT

*** This bug has been marked as a duplicate of bug 625910 ***

Note You need to log in before you can comment on or make changes to this bug.