Bug 624809 - Unable to change wrong static IP settings in askmethod URL install
Unable to change wrong static IP settings in askmethod URL install
Status: CLOSED DUPLICATE of bug 592856
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-17 16:08 EDT by Pasi Karkkainen
Modified: 2010-08-18 05:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-18 05:13:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pasi Karkkainen 2010-08-17 16:08:19 EDT
Description of problem:

Boot Fedora 13 x86_64 CD1 and press TAB to add "askmethod" option. Select the language (english), select keyboard type, and then select URL install. 

Select the NIC (eth0), and select manual settings, ipv4 only. 
Configure static IP info, but mistype DNS server IP on purpose (or usually accidentally). 

In the next step add URL of Fedora mirror site. 
Go further, and see the installer trying to fetch updates.img .. it actually says 100% complete, and then tries to fetch product.img, and again says 100% complete.. and then install.img, and again says 100% complete.. 

and then sfter a while it gives error "Unable to retrieve url/install.img". Go to CTRL-ALT-F3 and see errors about "could not resolve host name".

Then you realize you have mistyped the DNS server IP. You click BACK a couple of times to get to the install method selection, and choose URL method again. 

But now.. you don't get to re-configure the IP/nic settings! It goes straight to the URL submit screen..

So the only way to fix mistyped IP/DNS settings is to reboot..

Version-Release number of selected component (if applicable):
Fedora 13

How reproducible:
Always.

Steps to Reproduce:
1. Steps described above.
  
Actual results:
Cannot re-configure mistyped static IP/DNS settings.

Expected results:
It's possible to fix mistyped IP/DNS settings by going BACK in the installer.

Additional info:

None.
Comment 1 Radek Vykydal 2010-08-18 05:13:03 EDT

*** This bug has been marked as a duplicate of bug 592856 ***

Note You need to log in before you can comment on or make changes to this bug.