Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 624848 - Nouveau GPU hang when X starts on F13 with 7800GT
Nouveau GPU hang when X starts on F13 with 7800GT
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-17 18:15 EDT by Chris Ball
Modified: 2011-08-15 11:36 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-15 11:36:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (51.47 KB, text/plain)
2010-08-17 18:16 EDT, Chris Ball
no flags Details
xorg log (28.75 KB, text/x-log)
2010-08-17 18:17 EDT, Chris Ball
no flags Details

  None (edit)
Description Chris Ball 2010-08-17 18:15:14 EDT
Description of problem:

After upgrading to F13 and the 2.6.35 release, I see:

[drm] nouveau 0000:01:00.0: GPU lockup - switching to software fbcon

when starting X.  The initial console modeset works, though.

Version-Release number of selected component (if applicable):

xorg-x11-drv-nouveau-0.0.16-7.20100423git13c1043.fc13
Linux 2.6.35, manually compiled.

How reproducible:

Every time.

Steps to Reproduce:
1. Boot into runlevel 3
2. Type "X" at the console

Additional info:

dmesg and Xorg.0.log attached.
Comment 1 Chris Ball 2010-08-17 18:16:36 EDT
Created attachment 439234 [details]
dmesg
Comment 2 Chris Ball 2010-08-17 18:17:56 EDT
Created attachment 439235 [details]
xorg log
Comment 3 Chuck Ebbert 2010-08-18 08:35:49 EDT
You probably want to try 2.6.35.2-9.fc14, which has the nouveau updates from 2.6.36 added.
Comment 4 Chuck Ebbert 2010-09-03 08:22:03 EDT
What do you really want to report this against? F14 maybe? Right now it's against rawhide, which has 2.6.36-rc3
Comment 5 Martin Kho 2010-09-25 08:16:35 EDT
Hi,

I see the lockup message too, with kernel 2.6.36-0.26.rc5.git4.fc15.x86_64 and Fedora 15 (rawhide)

Excerpt from dmesg:
[drm] nouveau 0000:01:00.0: Allocating FIFO number 3
[drm] nouveau 0000:01:00.0: nouveau_channel_alloc: initialised FIFO 3
[drm] nouveau 0000:01:00.0: nouveau_channel_free: freeing fifo 3
[drm] nouveau 0000:01:00.0: Allocating FIFO number 3
[drm] nouveau 0000:01:00.0: nouveau_channel_alloc: initialised FIFO 3
[drm] nouveau 0000:01:00.0: GPU lockup - switching to software fbcon

lspci:
01:00.0 VGA compatible controller: nVidia Corporation G73 [GeForce 7600 GS] (rev a1) (prog-if 00 [VGA controller])
        Subsystem: ASUSTeK Computer Inc. Device 8206
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
        Region 1: Memory at c0000000 (64-bit, prefetchable) [size=512M]
        Region 3: Memory at fc000000 (64-bit, non-prefetchable) [size=16M]
        Region 5: I/O ports at dc00 [size=128]
        Expansion ROM at feae0000 [disabled] [size=128K]
        Capabilities: [60] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
                Address: 0000000000000000  Data: 0000
        Capabilities: [78] Express (v1) Endpoint, MSI 00
                DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <256ns, L1 <4us
                        ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                        RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
                        MaxPayload 128 bytes, MaxReadReq 512 bytes
                DevSta: CorrErr- UncorrErr+ FatalErr- UnsuppReq+ AuxPwr- TransPend-
                LnkCap: Port #0, Speed 2.5GT/s, Width x16, ASPM L0s L1, Latency L0 <256ns, L1 <4us
                        ClockPM- Surprise- LLActRep- BwNot-
                LnkCtl: ASPM Disabled; RCB 128 bytes Disabled- Retrain- CommClk+
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed 2.5GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
        Capabilities: [100 v1] Virtual Channel
                Caps:   LPEVC=0 RefClk=100ns PATEntryBits=1
                Arb:    Fixed- WRR32- WRR64- WRR128-
                Ctrl:   ArbSelect=Fixed
                Status: InProgress-
                VC0:    Caps:   PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
                        Arb:    Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
                        Ctrl:   Enable+ ID=0 ArbSelect=Fixed TC/VC=01
                        Status: NegoPending- InProgress-
        Capabilities: [128 v1] Power Budgeting <?>
        Kernel driver in use: nouveau
        Kernel modules: nouveau, nvidiafb
Comment 6 Martin Kho 2010-11-09 07:20:22 EST
Hi,

I don't see this message any more. Not sure what solved it, because I had some other nouveau issues.

Thanks,

Martin Kho

Currently running:
* kernel-2.6.36-1.fc15.x86_64
* xorg-x11-drv-nouveau-0.0.16-11.20101026git1143e7a.fc15.x86_64.rpm

Note You need to log in before you can comment on or make changes to this bug.