Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 624887 - [abrt] crash in bochs-2.4.2-1.fc13: bx_devices_c::init: Process /usr/bin/bochs was killed by signal 11 (SIGSEGV)
[abrt] crash in bochs-2.4.2-1.fc13: bx_devices_c::init: Process /usr/bin/boch...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: bochs (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
abrt_hash:1997c2accc23a96a3d65b6926ac...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-17 22:13 EDT by Aaron Hamid
Modified: 2010-11-05 09:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-05 09:56:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (30.73 KB, text/plain)
2010-08-17 22:13 EDT, Aaron Hamid
no flags Details

  None (edit)
Description Aaron Hamid 2010-08-17 22:13:27 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: bochs
component: bochs
crash_function: bx_devices_c::init
executable: /usr/bin/bochs
global_uuid: 1997c2accc23a96a3d65b6926ac475ca792851ea
kernel: 2.6.33.6-147.2.4.fc13.x86_64
package: bochs-2.4.2-1.fc13
rating: 4
reason: Process /usr/bin/bochs was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

comment
-----
[aaron@msi-cr620 bochs]$ gcc -v
Using built-in specs.
Target: x86_64-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk --disable-dssi --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre --enable-libgcj-multifile --enable-java-maintainer-mode --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --disable-libjava-multilib --with-ppl --with-cloog --with-tune=generic --with-arch_32=i686 --build=x86_64-redhat-linux
Thread model: posix
gcc version 4.4.4 20100630 (Red Hat 4.4.4-10) (GCC) 
[aaron@msi-cr620 bochs]$ ld -v
GNU ld version 2.20.51.0.2-20.fc13 20091009

How to reproduce
-----
followed instructions to compile and run sartoris tutorial

http://sartoris-microkernel.blogspot.com/2006/06/1.html

updated makefile to crosscompile to 32bit on 64bit machine: added -m32 to C*FLAGS, added -melf_i386 to ld

bochs 2.4.2-1.fc13 crashes on compiled image
Comment 1 Aaron Hamid 2010-08-17 22:13:31 EDT
Created an attachment (id=439276)
File: backtrace
Comment 2 Hans de Goede 2010-11-05 09:56:21 EDT
Hi,

Thanks for the bug report and sorry for the slow reply. I'm afraid I really do not have time to maintain bochs anymore. So I'm going to orphan this package. This means that for F-13 and F-14 it will stay at the current version and that it will be removed from the Fedora Package Collection for F-15 (unless someone else picks
it up).

Thanks & Regards,

Hans

p.s.

If you're looking a pc emulator qemu is the best choice now a days, which is also one of the reasons why I'm orphaning bochs.

Note You need to log in before you can comment on or make changes to this bug.