Bug 624908 - [a11y] openoffice.org -draw crashes with segfault after the most recent updates (1:openoffice.org-draw-3.3.0-4.3.fc14.i686)
Summary: [a11y] openoffice.org -draw crashes with segfault after the most recent updat...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-18 04:16 UTC by Joachim Backes
Modified: 2010-09-09 04:34 UTC (History)
2 users (show)

Fixed In Version: openoffice.org-3.3.0-6.2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-01 11:03:44 UTC


Attachments (Terms of Use)
strace -f openoffice.org -draw (1.57 MB, text/plain)
2010-08-18 04:16 UTC, Joachim Backes
no flags Details
gdb script to get backtrace (107 bytes, text/plain)
2010-08-18 06:40 UTC, David Tardon
no flags Details
/tmp/sdraw.bt (29.03 KB, text/plain)
2010-08-18 07:56 UTC, Joachim Backes
no flags Details
again: strace -f openoffice.org -draw (1.59 MB, text/plain)
2010-08-24 07:55 UTC, Joachim Backes
no flags Details

Description Joachim Backes 2010-08-18 04:16:08 UTC
Created attachment 439295 [details]
strace -f openoffice.org -draw

Description of problem:

After applying the new F14 updates:

openoffice.org -draw

** (soffice:4937): WARNING **: AT-SPI: Accessibility bus not found - 
Using session bus.

/usr/lib/openoffice.org3/program/soffice: line 116:  4937 Segmentation 
fault      (core dumped) "$sd_prog/$sd_binary" "$@"

No such problems with OO-writer oder OO-impress.

Version-Release number of selected component (if applicable):
openoffice.org-draw-3.3.0-4.3.fc14.i686)

How reproducible:
always

Steps to Reproduce:
1.See description
2.
3.
  
Actual results:
The oo window shortly appears, the disappears

Expected results:


Additional info:

Comment 1 Joachim Backes 2010-08-18 04:48:30 UTC
To be a little bit more precise: this happens only if I start oo-draw without a file to open. Starting it with an odg file argument: all is OK, the odg file is and remains opened.

Comment 2 David Tardon 2010-08-18 06:40:00 UTC
Created attachment 439306 [details]
gdb script to get backtrace

Could you 

yum --enablerepo=*debug install gdb openoffice.org-debuginfo

, save the attached file somewhere, run

gdb -nx -x bt.gdb /usr/lib/openoffice.org3/program/sdraw.bin

(it will require pressing enter several times, probably) and attach /tmp/sdraw.bt here?

Comment 3 David Tardon 2010-08-18 06:42:44 UTC
I should add that I cannot reproduce it on rawhide and don't have F-14 at hand.

Comment 4 Joachim Backes 2010-08-18 07:56:11 UTC
Created attachment 439315 [details]
/tmp/sdraw.bt

Comment 5 Caolan McNamara 2010-08-18 09:13:43 UTC
Works fine for me on x86_64 F14, though a11y seems sort of screwed up on Fedora 14 in general so a11y may simply not be working for me in order to trigger the bug

Comment 6 Caolan McNamara 2010-08-20 09:41:13 UTC
I think I can guess what this is now

Comment 7 Caolan McNamara 2010-08-20 09:58:45 UTC
Patch submitted upstream and checked in locally, attempted fix will be in 3.3.0-4.4

Comment 8 Fedora Update System 2010-08-23 07:45:47 UTC
openoffice.org-3.3.0-5.1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/openoffice.org-3.3.0-5.1.fc14

Comment 9 Fedora Update System 2010-08-23 19:03:45 UTC
openoffice.org-3.3.0-5.1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/openoffice.org-3.3.0-5.1.fc14

Comment 10 Joachim Backes 2010-08-24 05:09:34 UTC
I'm sorry, but 

openoffice.org -draw

** (soffice:8935): WARNING **: AT-SPI: Accessibility bus not found - Using session bus.

/usr/lib/openoffice.org3/program/soffice: line 116:  8935 Segmentation fault      (core dumped) "$sd_prog/$sd_binary" "$@"


rpm -qf /usr/bin/openoffice.org
openoffice.org-brand-3.3.0-5.1.fc14.i686


rpm -qf /usr/lib/openoffice.org3/program/soffice
openoffice.org-brand-3.3.0-5.1.fc14.i686

Comment 11 Caolan McNamara 2010-08-24 07:40:30 UTC
A pity, there must be another similar bug in here somewhere.

Comment 12 Joachim Backes 2010-08-24 07:55:21 UTC
Created attachment 440584 [details]
again: strace -f openoffice.org -draw

Comment 13 Caolan McNamara 2010-08-24 14:33:06 UTC
straces don't help for this type of problem.

a11y in sd is a total ball of mud

Comment 14 Caolan McNamara 2010-08-24 14:59:22 UTC
Lets try another approach, building as openoffice.org-3.3.0-f.2.fc14

Comment 15 Fedora Update System 2010-08-27 03:06:40 UTC
openoffice.org-3.3.0-5.1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Joachim Backes 2010-08-27 06:43:52 UTC
Something wrong?

On my box, the binary "openoffice.org" belongs to  "openoffice.org-brand-3.3.0-5.1.fc14.i686", not to any package called "openoffice.org-3.3.0-5.1.fc14".

There is no package openoffice.org on my box.

rpm -qi openoffice.org-brand-3.3.0-5.1.fc14.i686
Name        : openoffice.org-brand         Relocations: (not relocatable)
Version     : 3.3.0                             Vendor: Fedora Project
Release     : 5.1.fc14                      Build Date: Fri 20 Aug 2010 07:20:30 PM CEST
Install Date: Tue 24 Aug 2010 06:20:00 AM CEST      Build Host: x86-12.phx2.fedoraproject.org
Group       : Applications/Productivity     Source RPM: openoffice.org-3.3.0-5.1.fc14.src.rpm
Size        : 888967                           License: LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and (CDDL or GPLv2) and Public Domain
Signature   : RSA/SHA256, Mon 23 Aug 2010 05:29:25 PM CEST, Key ID 421caddb97a1071f
Packager    : Fedora Project
URL         : http://www.openoffice.org/
Summary     : Core brand for OpenOffice.org
Description :

Comment 17 Caolan McNamara 2010-08-27 12:51:47 UTC
This damn a11y crash still persists, need to get somewhat medieval on it

Comment 18 Caolan McNamara 2010-08-27 12:52:36 UTC
I've updated upstream workaround patch and new build underway

Comment 19 Fedora Update System 2010-08-30 15:14:24 UTC
openoffice.org-3.3.0-6.1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/openoffice.org-3.3.0-6.1.fc14

Comment 20 Fedora Update System 2010-08-30 19:42:43 UTC
openoffice.org-3.3.0-6.1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/openoffice.org-3.3.0-6.1.fc14

Comment 21 Joachim Backes 2010-09-01 11:03:44 UTC
Works for me.

Comment 22 Fedora Update System 2010-09-07 07:53:49 UTC
openoffice.org-3.3.0-6.2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/openoffice.org-3.3.0-6.2.fc14

Comment 23 Fedora Update System 2010-09-09 04:34:16 UTC
openoffice.org-3.3.0-6.2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.