Bug 624938 - Man page for setroubleshootd mentions option not supported by the binary
Summary: Man page for setroubleshootd mentions option not supported by the binary
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: setroubleshoot   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Miroslav Grepl
QA Contact: Milos Malik
URL:
Whiteboard:
Keywords: Documentation
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-18 07:36 UTC by David Kutálek
Modified: 2015-09-14 15:24 UTC (History)
3 users (show)

Fixed In Version: setroubleshoot-3.0.38-2.el6
Doc Type: Bug Fix
Doc Text:
Prior to this update, the setroubleshootd man page described an option that was not supported by the setroubleshootd service. This update corrects the man page content by removing the unsupported option.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 09:46:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1509 normal SHIPPED_LIVE setroubleshoot bug fix update 2011-12-06 00:39:33 UTC

Description David Kutálek 2010-08-18 07:36:14 UTC
Description of problem:

Man page for setroubleshootd is describing option, which is actually not supported by the binary:

Man:
...
OPTIONS
       -b --browser
              Launch the browser
...

Binary:
[root@timothy]# setroubleshootd --browser

-f --nofork				no fork
-c --config section.option=value	set a configuration value
-v --verbose                            log INFO level and higher messages to console
-V --debug                              log DEBUG level and higher messages to console
-h --help				display help info


Version-Release number of selected component (if applicable):

setroubleshoot-2.2.91-1.el6.x86_64

How reproducible:

Always

Steps to Reproduce:
1. man setroubleshootd
2. setroubleshootd --browser
3.
  
Actual results:

Described above

Expected results:

-b and --browser should be removed from man page since not supported.

Additional info:

Comment 2 Daniel Walsh 2010-11-22 21:27:51 UTC
I would prefer to push off setroubleshoot to see how well the redesign in Fedora 15 goes, and then update to that package in 6.2.

Comment 3 Daniel Walsh 2011-05-23 18:51:21 UTC
Fixed in setroubleshoot-3.0.31-1.el6

Comment 5 Petr Kovar 2011-07-04 17:14:02 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Prior to this update, the setroubleshootd man page described an option that was not supported by the setroubleshootd service. This update corrects the man page content by removing the unsupported option.

Comment 7 Miroslav Grepl 2011-09-15 08:33:08 UTC
Fixed in setroubleshoot-3.0.38-2.el6

Comment 10 errata-xmlrpc 2011-12-06 09:46:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1509.html


Note You need to log in before you can comment on or make changes to this bug.