Bug 624940 - [qemu] [rhel6] qemu guest machine freezes when it hit kernel panic
[qemu] [rhel6] qemu guest machine freezes when it hit kernel panic
Status: CLOSED DUPLICATE of bug 624721
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Luiz Capitulino
Virtualization Bugs
: RHELNAK
Depends On:
Blocks: 580953
  Show dependency treegraph
 
Reported: 2010-08-18 03:44 EDT by Haim
Modified: 2014-01-12 19:47 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-01 06:42:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Haim 2010-08-18 03:44:02 EDT
Description of problem:

qemu guest machine freeze when it hit kernel panic. 
monitor socket doesn't respond at all. 

[root@silver-vdse tmp]# nc -U /var/lib/libvirt/qemu/boom-path.monitor 
{"QMP": {"version": {"qemu": "0.12.1", "package": "(qemu-kvm-0.12.1.2)"}, "capabilities": []}}

it happened when I passed kernel boot options via qemu-exec command line: 

LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin QEMU_AUDIO_DRV=none /usr/libexec/qemu-kvm -S -M rhel6.0.0 -cpu qemu64,-svm -enable-kvm -m 512 -smp 1,sockets=1,cores=1,threads=1 -name boom-path -uuid 21bab490-5502-4630-b91b-81ab19859b2d -nodefconfig -nodefaults -chardev socket,id=monitor,path=/var/lib/libvirt/qemu/boom-path.monitor,server,nowait -mon chardev=monitor,mode=control -rtc base=2010-7-18T7:0:55 -boot cn -kernel /tmp/vmlinuz-2.6.18-194.8.1.el5 -initrd /tmp/initrd-2.6.18-194.8.1.el5.img -device virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0,addr=0x5 -drive file=/rhev/data-center/6acd4aff-334a-44e1-8370-048f1ba9962b/6c4717af-38c1-47ea-846d-e8ecea1cd633/images/c3457abf-c881-4ce9-a112-8c487f3105ea/77c58566-3ff4-4662-84b8-6f544022c840,if=none,id=drive-virtio-disk0,boot=on,format=qcow2,serial=e9-a112-8c487f3105ea,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,bus=pci.0,addr=0x6,drive=drive-virtio-disk0,id=virtio-disk0 -drive file=/rhev/data-center/6acd4aff-334a-44e1-8370-048f1ba9962b/6c4717af-38c1-47ea-846d-e8ecea1cd633/images/cfc1512a-3da8-47cb-91d2-fabd0d3c00dc/877d47dd-28:


repro steps: 

1) install vm with rhel54 
2) copy initrd and vmlinuz files to your hosts (which are higher then your host 
   currently has)
3) pass those parameters to qemu
4) start vm 

21570 vdsm      20   0  854m  75m 3028 S 106.2  0.2  47:19.80 qemu-kvm                                                                                         

qemu process takes 100%


2.6.32-59.1.el6.x86_64
libvirt-0.8.1-23.el6.x86_64
vdsm-4.9-12.3.x86_64
device-mapper-multipath-0.4.9-25.el6.x86_64
lvm2-2.02.72-4.el6.x86_64
qemu-kvm-0.12.1.2-2.109.el6.x86_64
Comment 2 RHEL Product and Program Management 2010-08-18 04:18:09 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 3 Luiz Capitulino 2010-11-29 13:25:27 EST
Just tried to reproduce this one following the steps described in the description but it does work for me. Tested with qemu-kvm-0.12.1.2-2.113.el6.x86_64 and latest checkout from Eduardo's repository (HEAD 76a4a8cfb6a).

I really think this is a dupe of bug 624721, can you please check?
Comment 4 Luiz Capitulino 2010-12-01 06:42:50 EST

*** This bug has been marked as a duplicate of bug 624721 ***

Note You need to log in before you can comment on or make changes to this bug.