Bug 624973 - Broken directory coping
Summary: Broken directory coping
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mc   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-18 09:28 UTC by Mikhail Kalenkov
Modified: 2013-07-02 23:47 UTC (History)
6 users (show)

Fixed In Version: mc-4.7.4-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-15 07:15:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mikhail Kalenkov 2010-08-18 09:28:02 UTC
Description of problem:
Last mc update is broken. 

Version-Release number of selected component (if applicable):
mc-4.7.3-1.fc13

How reproducible:
always


Steps to Reproduce:
1. mkdir -p ~/test1/test/
2. mkdir -p ~/test2/test/
3. mc ~/test1/ ~/test2/
4. Select test directory from the left panel and press F5 (copy)
  
Actual results:
Steps 1-4 produces two directory trees
~/test1/test/test/
~/test2/test/

Surprisingly ~/test2/test/ directory is copied as a subdirectory of ~/test1/test/

Expected results:
~/test1/test/
~/test2/test/

Additional info:

Comment 1 Mikhail Kalenkov 2010-08-18 11:37:40 UTC
The bug is not reproduced with mc-4.7.2-2.fc13.

Comment 2 Mikhail Kalenkov 2010-09-01 14:40:49 UTC
ping

I found this bug in mc bugtracker

http://www.midnight-commander.org/ticket/2276

Current version of the mc is completely useless for me due to this bug.

Comment 3 Fedora Update System 2010-09-02 16:27:21 UTC
mc-4.7.3-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/mc-4.7.3-2.fc13

Comment 4 Fedora Update System 2010-09-02 16:27:36 UTC
mc-4.7.3-2.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/mc-4.7.3-2.fc12

Comment 5 Fedora Update System 2010-09-02 16:27:49 UTC
mc-4.7.3-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/mc-4.7.3-2.fc14

Comment 6 Fedora Update System 2010-09-02 20:34:18 UTC
mc-4.7.3-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mc'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/mc-4.7.3-2.fc12

Comment 7 Mikhail Kalenkov 2010-09-03 05:03:55 UTC
(In reply to comment #3)
> mc-4.7.3-2.fc13 has been submitted as an update for Fedora 13.
> https://admin.fedoraproject.org/updates/mc-4.7.3-2.fc13

Testing release mc-4.7.3-2.fc13 fixes this bug. Many thanks.

Comment 8 rvcsaba 2010-09-03 11:33:16 UTC
Please see my bug report:

https://bugzilla.redhat.com/show_bug.cgi?id=629679

Comment 9 Fedora Update System 2010-09-07 17:33:47 UTC
mc-4.7.4-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/mc-4.7.4-1.fc13

Comment 10 Fedora Update System 2010-09-07 17:34:12 UTC
mc-4.7.4-1.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/mc-4.7.4-1.fc12

Comment 11 Fedora Update System 2010-09-07 17:34:35 UTC
mc-4.7.4-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/mc-4.7.4-1.fc14

Comment 12 Fedora Update System 2010-09-15 07:15:17 UTC
mc-4.7.4-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 rvcsaba 2010-09-15 08:43:16 UTC
You closed this bug, but you don't read my #629679 bug report? This change poduce a regression.

Comment 14 Jindrich Novy 2010-09-15 09:07:47 UTC
Bug #629679 is a different issue and upstream currently works on it.

Comment 15 rvcsaba 2010-09-15 09:29:03 UTC
Hm... Bug #629679 appear in mc-4.7.3-2.


           #624973   #629679
4.7.3-1     Bad       Good
4.7.3-2     Good      Bad
4.7.4-1     Good      Bad

Comment 16 Fedora Update System 2010-09-15 22:26:49 UTC
mc-4.7.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2010-09-15 22:32:00 UTC
mc-4.7.4-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.