Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 62499 - "linux dd" process fails to update initrd
"linux dd" process fails to update initrd
Status: CLOSED DUPLICATE of bug 62213
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-01 15:42 EST by Justin T. Gibbs
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-12 23:45:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Aic79xx Driver Disket for Skipjack2 (189.42 KB, application/octet-stream)
2002-04-12 23:44 EDT, Justin T. Gibbs
no flags Details

  None (edit)
Description Justin T. Gibbs 2002-04-01 15:42:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Installation using a third party driver diskette succeeds, but
all successive boots fails to find the appropriate driver.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Generate a driver diskette using Doug Ledford's DD framework
2.Boot installation CD with "linux dd"
3.Insert disket when prompted
4.Install to media only accessible vi "dd" driver.
5.Reboot
5.Notice that system cannot find the installation device.	

Actual Results:  The installer appears to fail to update /etc/modules.conf
and to regenerate the initrd to include the module from the
driver diskette.  If, just before quiting the installation,
the emergency shell is used to update /etc/modules.conf and
the initrds, all goes well.

Expected Results:  You should be able to install to and subsequently boot from a
device that is only supported via a driver diskette

Additional info:
Comment 1 Jeremy Katz 2002-04-01 16:08:28 EST

*** This bug has been marked as a duplicate of 62213 ***
Comment 2 Justin T. Gibbs 2002-04-12 23:44:11 EDT
This bug is still reproducible in Skipjack2.  With that beta:

1) The DD's modules are not extracted to /lib/modules
2) No initrd is created
3) Grub is not updated to look for an initrd.

However, /etc/modules.conf is correct.

Attached is the driver diskette image we used to attempt our install.
Included, in the directory "sample" in the image, are /boot/grub/grub.conf,
/etc/modules.conf and an ls -LR of /lib/modules (all relative to /mnt/sysimage)
from the emergency install shell just prior to the reboot after installing
the OS.
Comment 3 Justin T. Gibbs 2002-04-12 23:44:57 EDT
Created attachment 53704 [details]
Aic79xx Driver Disket for Skipjack2
Comment 4 Jeremy Katz 2002-04-14 02:10:31 EDT
Yes, it didn't get fixed until after the freeze for Skipjack-beta2 which was why
I put up disks for testing.

*** This bug has been marked as a duplicate of 62213 ***

Note You need to log in before you can comment on or make changes to this bug.