Bug 62504 - DHCP doesn't server BOOTP clients correctly
DHCP doesn't server BOOTP clients correctly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Beth Uptagrafft
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-01 17:00 EST by harry.heinisch
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-17 18:49:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample /etc/dhcpd.conf file as used for testing (1.78 KB, text/plain)
2002-04-01 17:03 EST, harry.heinisch
no flags Details
Binary dhcpd to test (42.04 KB, application/octet-stream)
2002-04-17 18:49 EDT, Phil Copeland
no flags Details

  None (edit)
Description harry.heinisch 2002-04-01 17:00:19 EST
Description of Problem: DHCP doesn't serve BOOTP clients correctly


Version-Release number of selected component (if applicable): RH72-alpha-beta2


How Reproducible: Always.


Steps to Reproduce:
1. configure DHCP to serve BOOTP clients (see sample config attached)
2. observe DHCP logging BOOTREQUESTs and BOOTREPLY messages
3. observe client not receiving BOOTREPLY message

Actual Results: client never appears to receive the BOOTREPLY message
                that the server is supposed to send out.


Expected Results: client should receive a message indicating various
                  information about how it is supposed to proceed.


Additional Information: TFTP is configured and working, as I can bypass the
                        DHCP server and go directly to TFTP from a client
                        and receive the desired file.

                        NOTE: the 7.2 x86 version of DHCP seems to have the same
                        problem, so either both are broken or there's something
                        I don't understand about how this is supposed to work.
Comment 1 harry.heinisch 2002-04-01 17:03:54 EST
Created attachment 51688 [details]
sample /etc/dhcpd.conf file as used for testing
Comment 2 harry.heinisch 2002-04-02 09:23:53 EST
Rebuilt and replaced /usr/sbin/dhcp from the dhcp-2.0p15-8.src.rpm via:

	./configure
	make
	cp server/dhcpd /usr/sbin

Had to do:
	mkdir -p /var/state/dhcp
	touch /var/state/dhcp/dhcpd.leases

It then immediately started serving requests correctly.

Perhaps the binary RPM has an older or mis-configured server in it?
Comment 3 harry.heinisch 2002-04-02 10:23:52 EST
OK; I tracked it down to the args used to invoke "./configure' with.

If you don't leave the first argument null (via "", I think), it won't
get the Linux major/minor version info correct, and this will lead to a
mis-configure of the server (at least), because of dependency on the
symbol LINUX_MAJOR in includes/cf/linux.h.

It looks as if it might be easier to patch "configure" rather than figure
out a way to pass a null first arg... ;-}
Comment 4 Phil Copeland 2002-04-17 18:47:21 EDT
Ok,.. I'm looking at dhcpd-1.3.22pl1-7
I've built an rpm that I want throw your way as I don't have a suitable
enviroment here to test this with.

(Elliot, I've had to add automake and a "" to %configure in the spec file to get
this to compile on the alpha.)

Phil
=--=
Comment 5 Phil Copeland 2002-04-17 18:49:42 EDT
Created attachment 54264 [details]
Binary dhcpd to test
Comment 6 Phil Copeland 2002-04-21 23:38:08 EDT
Wel, no news is good news,.. I'm out of time so this is going in as fixed for
the next cycle.

Elliot be advised that this is being flagged as a generic bug

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.