Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 625062 - Unneeded dependency on policycoreutils
Unneeded dependency on policycoreutils
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jadetex (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-18 10:10 EDT by Jindrich Novy
Modified: 2013-07-02 19:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: jadetex-3.13-9.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-31 04:54:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jindrich Novy 2010-08-18 10:10:28 EDT
Description of problem:
jadetex package contains the following %post scriptlet dependency:
Requires(post): policycoreutils

This dependency is not needed and causes dependency bloat because 63k jadetex package pulls in additional 2M of dependencies (policycoreutils and checkpolicy as its dependency) even on a system without SELinux enabled.

Correct SELinux context restoration could be made only when SELinux is installed/enabled on a system. Likely in a similar way how it is done in TeX Live packages:

%post
if [ -x /usr/sbin/selinuxenabled ] && /usr/sbin/selinuxenabled; then
  [ -x /sbin/restorecon ] && /sbin/restorecon -R %{_texmf_var}/
fi
:


Version-Release number of selected component (if applicable):
jadetex-3.13-8.fc15

How reproducible:
Always

Steps to Reproduce:
1. rpm -q --requires jadetex | grep policycoreutils | wc -l
2.
3.
  
Actual results:
1

Expected results:
0
Comment 1 Ondrej Vasik 2010-08-18 10:15:27 EDT
Thanks for filling the bug, as discussed via IRC, I'll remove the dependency in next jadetex rawhide build.
Comment 2 Ondrej Vasik 2010-08-31 04:54:31 EDT
Fixed in jadetex-3.13-9.fc15, closing RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.