Bug 625081 - SELinux is preventing /usr/sbin/rpc.gssd "getattr" access on /tmp/krb5cc_510_8YfbKD.
SELinux is preventing /usr/sbin/rpc.gssd "getattr" access on /tmp/krb5cc...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:b22974ddd62...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-18 10:47 EDT by Frederic Riss
Modified: 2010-08-19 05:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-19 04:38:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frederic Riss 2010-08-18 10:47:39 EDT
Summary:

SELinux is preventing /usr/sbin/rpc.gssd "getattr" access on
/tmp/krb5cc_510_8YfbKD.

Detailed Description:

SELinux denied access requested by rpc.gssd. It is not expected that this access
is required by rpc.gssd and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:gssd_t:s0
Target Context                system_u:object_r:sshd_tmp_t:s0
Target Objects                /tmp/krb5cc_510_8YfbKD [ file ]
Source                        rpc.gssd
Source Path                   /usr/sbin/rpc.gssd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           nfs-utils-1.2.1-5.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-118.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.32.16-150.fc12.i686 #1 SMP Sat Jul 24 05:31:53
                              UTC 2010 i686 i686
Alert Count                   7
First Seen                    Thu 12 Aug 2010 07:50:21 PM CEST
Last Seen                     Thu 12 Aug 2010 09:21:30 PM CEST
Local ID                      edd1ac99-06b8-46d0-8e90-6b4e52a85bd2
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1281640890.305:279): avc:  denied  { getattr } for  pid=1306 comm="rpc.gssd" path="/tmp/krb5cc_510_8YfbKD" dev=sda2 ino=55625 scontext=system_u:system_r:gssd_t:s0 tcontext=system_u:object_r:sshd_tmp_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1281640890.305:279): arch=40000003 syscall=196 success=no exit=-13 a0=bf94b3dc a1=bf94aea8 a2=637ff4 a3=1 items=0 ppid=1 pid=1306 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="rpc.gssd" exe="/usr/sbin/rpc.gssd" subj=system_u:system_r:gssd_t:s0 key=(null)



Hash String generated from  catchall,rpc.gssd,gssd_t,sshd_tmp_t,file,getattr
audit2allow suggests:

#============= gssd_t ==============
allow gssd_t sshd_tmp_t:file getattr;
Comment 1 Frederic Riss 2010-08-19 02:47:11 EDT
This happens each time I log in. Our setup uses Kerberos 5 + LDAP for authentification and NFSv4 for home dirs (although I don't think NFS matters for the issue at hand).
Comment 2 Frederic Riss 2010-08-19 04:38:50 EDT
Nevermind, I tweaked the booleans to allow gssd to read /tmp and this disappeared.
Comment 3 Miroslav Grepl 2010-08-19 05:29:07 EDT
Looks like you have partially updated system. Probably you need to complete upgrade.

Note You need to log in before you can comment on or make changes to this bug.