Bug 625112 - [abrt] tracker-0.8.15-2.fc13: gst_base_src_get_range: Process /usr/libexec/tracker-extract was killed by signal 11 (SIGSEGV)
[abrt] tracker-0.8.15-2.fc13: gst_base_src_get_range: Process /usr/libexec/tr...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: tracker (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
abrt_hash:5634c5fec797fefcc617fd4914f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-18 11:59 EDT by Felipe Hommen
Modified: 2010-08-18 12:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-18 12:29:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (98.46 KB, text/plain)
2010-08-18 11:59 EDT, Felipe Hommen
no flags Details

  None (edit)
Description Felipe Hommen 2010-08-18 11:59:00 EDT
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: /usr/libexec/tracker-extract
component: tracker
crash_function: gst_base_src_get_range
executable: /usr/libexec/tracker-extract
kernel: 2.6.33.6-147.2.4.fc13.x86_64
package: tracker-0.8.15-2.fc13
rating: 4
reason: Process /usr/libexec/tracker-extract was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
time: 1282147042
uid: 1000
Comment 1 Felipe Hommen 2010-08-18 11:59:04 EDT
Created an attachment (id=439422)
File: backtrace
Comment 2 Deji Akingunola 2010-08-18 12:29:18 EDT
As revealed in the attached backtrace, the crash occurred when tracker was trying to index "file:///home/felipe/mnt/baul/openclipart/office/pen_pencil_darkon_01.svg". I got a copy of this file from the internet and tried to reproduce the bug. But I couldn't reproduced it (as shown below);

Cc'ing gstreamer maintainer in case he find an issue with the backtrace.

>>>
[]$ /usr/libexec/tracker-extract -f pen_pencil_darkon_01.svg
Initializing tracker-extract...
Initializing Storage...
....
Adding extractor:'/usr/lib64/tracker-0.8/extract-modules/libextract-jpeg.so' with:
  Specific match for mime:'image/jpeg'
<--- [1] tracker_extract_get_metadata_by_cmdline(uri:'file:///home/deji/Downloads/petsc-3.1-p4/pen_pencil_darkon_01.svg', mime:(null))
---- [1]   Guessing mime type as 'image/svg+xml' for uri:'file:///home/deji/Downloads/petsc-3.1-p4/pen_pencil_darkon_01.svg'
---- [1]   Extracting with module:'/usr/lib64/tracker-0.8/extract-modules/libextract-gstreamer.so'
Processing album art, buffer is 0 bytes, artist:'', album:'', filename:'file:///home/deji/Downloads/petsc-3.1-p4/pen_pencil_darkon_01.svg', mime:'(null)'
Album art path could not be obtained, not processing any further
---- [1]   Found 1 metadata items
---- [1] 
---- [1]  a nfo:Image .

---> [1] Success, no error given
>>>>

Feel free to re-open the bug if you can find other ways to reproduce the bug.

Note You need to log in before you can comment on or make changes to this bug.