Bug 625180 - [abrt] terminator-0.94-1.fc13: titlebar.py:105:update:AttributeError: 'str' object has no attribute 'group'
Summary: [abrt] terminator-0.94-1.fc13: titlebar.py:105:update:AttributeError: 'str' o...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: terminator   
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Dominic Hopf
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:aa29d92d
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-18 19:23 UTC by William SK
Modified: 2010-09-02 19:22 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-02 19:22:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (919 bytes, text/plain)
2010-08-18 19:23 UTC, William SK
no flags Details

Description William SK 2010-08-18 19:23:23 UTC
abrt version: 1.1.13
architecture: x86_64
cmdline: /usr/bin/python /usr/bin/terminator -l Remote
component: terminator
executable: /usr/bin/terminator
kernel: 2.6.33.6-147.2.4.fc13.x86_64
package: terminator-0.94-1.fc13
reason: titlebar.py:105:update:AttributeError: 'str' object has no attribute 'group'
release: Fedora release 13 (Goddard)
time: 1282158551
uid: 502

backtrace
-----
titlebar.py:105:update:AttributeError: 'str' object has no attribute 'group'

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/terminatorlib/window.py", line 189, in on_focus_out
    terminal.on_window_focus_out()
  File "/usr/lib/python2.6/site-packages/terminatorlib/terminal.py", line 986, in on_window_focus_out
    self.titlebar.update('window-focus-out')
  File "/usr/lib/python2.6/site-packages/terminatorlib/titlebar.py", line 105, in update
    if term != other and term.group and term.group == other.group:
AttributeError: 'str' object has no attribute 'group'

Local variables in innermost frame:
default_bg: False
term: <Terminal object at 0x207e0f0 (terminatorlib+terminal+Terminal at 0x20fc0f0)>
other: 'window-focus-out'
terminator: <terminatorlib.terminator.Terminator instance at 0x2075b00>
self: <Titlebar object at 0x207e1e0 (terminatorlib+titlebar+Titlebar at 0x20fc210)>

comment
-----
The group name I entered was a single, lowercase word, and I hit enter when done.
There were three terminals open at the time in terminator and this happened when creating the group,
adding the second terminal to the group didn't produce this message.  Also, terminator didn't crash.

How to reproduce
-----
1. Open a terminator session, do some work for a while
2. Click on the icon in the upper left and choose 'New group...'
3. Enter a word in the box and then hit enter when done, then this error pops up

Comment 1 William SK 2010-08-18 19:23:25 UTC
Created an attachment (id=439477)
File: backtrace

Comment 2 Dominic Hopf 2010-08-18 23:10:48 UTC
Thanks very much for reporting the issue. I'm sorry for my spare time and my rare answer. I guess this issue is concerned upstream, thus I'll report it to upstream next week.

Comment 3 William SK 2010-08-20 14:20:08 UTC
No need to rush, I'm sorry if I wasn't clear in my above statement, but terminator still runs fine after this crash, it is just an abrt message, and therefore a very minor nuisance.  Thanks for a kick-ass and very useful program!

Comment 4 tommy9874 2010-08-24 07:45:20 UTC
Package: terminator-0.94-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. not sure
2.
3.

Comment 5 Łukasz Jernaś 2010-08-25 08:11:02 UTC
Package: terminator-0.94-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Open terminator from Programs menu
2. Press Ctrl+Shift+O to split horizontally
3. Press Super+G to group terminals

Comment 6 Dominic Hopf 2010-08-28 12:07:00 UTC
There is Terminator 0.95 available in updates-testing repository. I can not reproduce the steps with this version. Would it be possible for you to try reproducing this issue with Terminator 0.95?

You can update via `yum -y update terminator --enablerepo=updates-testing`.

Comment 7 Łukasz Jernaś 2010-08-28 22:38:46 UTC
It works for me with 0.95.

Comment 8 William SK 2010-08-30 13:35:13 UTC
Terminator 0.95 does not seem to have this bug.  It works fine for me.

Comment 9 Angus Salkeld 2010-09-01 22:31:33 UTC
Package: terminator-0.94-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. 4 windows
2. created a group "dashers"
3. added 3 windows to that group

Comment 10 Angus Salkeld 2010-09-01 22:53:26 UTC
Yip, fixed in 0.95.

Comment 11 Dominic Hopf 2010-09-02 19:22:43 UTC
Thanks very much for your feedback guys. I just marked the update as stable and thus, will close this bug. Feel free to reopen in case you find a remaining regression concerning this issue. :)


Note You need to log in before you can comment on or make changes to this bug.