Bug 62521 - startx fails using ATI Xpert 128 card
startx fails using ATI Xpert 128 card
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-04-01 20:58 EST by Martin May
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-04-03 10:49:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/var/log/XFree86.0.log from failing machine (11.35 KB, text/plain)
2002-04-01 21:02 EST, Martin May
no flags Details

  None (edit)
Description Martin May 2002-04-01 20:58:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (Win98; U)

Description of problem:
Linux 7.2 installed cleanly and boots and functions normally in text mode.  When startx is issued, message received:
Fatal server error:
no screens found
Video card is ATI Xpert 128.  Hardware list says its compatable.  I tried installing XFree86-SVGA and dependents with
no success.  Tried running Xconfigurator several times.  Card is correctly probed, monitor is correctly probed.  Monitor 
is Viewsonic A70f. I saw three other reports of this error on the web site, all in March of this year, but did not see any
resolutions.  Please help!

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Boot (run level 5 fails and system reverts to run level 3)
2.From any login, issue startx
3.Much message traffic culminating in message: Fatal server error:  no screens found.  I have /var/log/XFree86.0.log if necessary just say how to 
send it if needed.  I would have to do it via a Windows machine, the Linux machine is not networked yet.  The messages in the log all look normal 
until the very last one.

Expected Results:  Gnome or KDE should have been presented

Additional info:
Comment 1 Martin May 2002-04-01 21:02:35 EST
Created attachment 51724 [details]
/var/log/XFree86.0.log from failing machine
Comment 2 Mike A. Harris 2002-04-03 09:17:24 EST
Rage 128 PP card is not officially supported.  You can upgrade to
our erratum release (4.1.0-15 or later) in order to test preliminary
support I wrote.  If that doesn't work, your best bet is to wait until
our next distro release as it is supported in 4.2.0, however I dont
know if it works or not as I dont have one to test with.
Comment 3 Martin May 2002-04-03 10:49:03 EST
I'm new to Linux and am not sure what you main about "upgrading" to "erratum release (4.1.0-15 or later)".  If I am having a problem with Linux
7.2, how can "erratum release (4.1.0-15 or later)" be more current?  Or, is this a release of just XFree86?  How do I get the errata release?

Finally, you say that the ATI Xpert 128 is not officially supported.  Then, why does it show up on the Hardware compatability list as supported 
and, in fact, has a ease of installation rating of 4?  If the errata release doesn't work, I can try a different card, but then how will I know which card 
to buy if I can't trust the Hardware Compatability list?

I'd appreciate it if you could clarify these issues for me!
Comment 4 Mike A. Harris 2002-04-03 11:16:38 EST
Those are all technical support questions, however bugzilla is explicitly
not a technical support forum.  You can find answers to those questions
on our mailing lists, or other methods of support.

I am saying ATI Rage 128 chip model PP with PCI ID 1002:5050 is not
officially supported.  I know that because I specifically wrote the code

As for the hardware compatibility list, as far as video is concerned, it
is totally out of date and unreliable.  I dont know if our video list is
kept up to date or accurate at all as I'm not in any way affiliated with
the hardware compatibility list.  The official list of supported video
hardware down to the PCI ID level does not exist.  XFree86.org's status
document is a general guideline of what is supported, but does not go
into detail of PCI ID's.  The _ONLY_ way to know if it is supported or
not is to look into the source code, and preferably test it out

Please do not reopen bug reports after they've been closed as fixed,
unless you've tested the fix given in the resolution and found it to not
work.  Again, bugzilla is not a tech support forum, it is a bug tracking

Re-closing as fixed in RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.