Bug 62526 - Bash doesn't work with make
Summary: Bash doesn't work with make
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: wdovlrrw
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-02 03:47 UTC by hjl
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-02 03:48:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A Makefile to show the bash bug (113 bytes, text/plain)
2002-04-02 03:48 UTC, hjl
no flags Details

Description hjl 2002-04-02 03:47:57 UTC
# make
if [ -n "" ]; then \
  for r in ; do \
    echo $r; \
  done; \
fi
/tmp/bash: -c: line 1: syntax error near unexpected token `;'
/tmp/bash: -c: line 1: `if [ -n "" ]; then  for r in ; do  echo $r;  done;  fi'
make: *** [all] Error 2

Bash in RedHat 7.1 and the current public beta are ok.

Comment 1 hjl 2002-04-02 03:48:38 UTC
Created attachment 51744 [details]
A Makefile to show the bash bug

Comment 2 Bernhard Rosenkraenzer 2002-04-02 10:42:05 UTC
This is because  
  
for i in ; do something; done  
        ^nothing  
  
isn't part of older standards. 
Support for this construct has been added in 2.05. 


Comment 3 hjl 2002-04-02 16:49:00 UTC
It is a regression from RedHat 7.1. The build stops working
after upgrading to RedHat 7.2.


Note You need to log in before you can comment on or make changes to this bug.