Bug 625317 - device-mapper-devel package incorrectly requires device-mapper, when it should probably only need device-mapper-libs, not both
device-mapper-devel package incorrectly requires device-mapper, when it shoul...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: device-mapper-obsolete (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-19 00:23 EDT by Jasper O'neal Hartline
Modified: 2010-08-19 08:00 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-19 06:51:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jasper O'neal Hartline 2010-08-19 00:23:17 EDT
Description of problem:
Description is in the summary.

Error: Package: device-mapper-devel-1.02.44-1.fc13.i686 (fedora)
            Requires: device-mapper = 1.02.44-1.fc13


repoquery --list device-mapper shows no files device-mapper-devel needs.

/lib/udev
/lib/udev/rules.d
/lib/udev/rules.d/10-dm.rules
/lib/udev/rules.d/13-dm-disk.rules
/lib/udev/rules.d/95-dm-notify.rules
/sbin/dmsetup
/usr/share/doc/device-mapper-1.02.44
/usr/share/doc/device-mapper-1.02.44/12-dm-permissions.rules
/usr/share/doc/device-mapper-1.02.44/COPYING
/usr/share/doc/device-mapper-1.02.44/COPYING.LIB
/usr/share/doc/device-mapper-1.02.44/INSTALL
/usr/share/doc/device-mapper-1.02.44/README
/usr/share/doc/device-mapper-1.02.44/VERSION_DM
/usr/share/doc/device-mapper-1.02.44/WHATS_NEW_DM
/usr/share/man/man8/dmsetup.8.gz

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Alasdair Kergon 2010-08-19 06:51:26 EDT
The dependencies are kept minimal.  You need the udev files in place to make any use of device-mapper in Fedora now, we will not support any users without dmsetup being installed anyway and the documentation files have to be there too.
Comment 2 Jasper O'neal Hartline 2010-08-19 07:28:35 EDT
I have device-mapper installed, just not a version yum-builddep on anaconda.src.rpm file wanted. I don't see how needing device-mapper-devel to build anaconda against requires device-mapper at all.
Comment 3 Alasdair Kergon 2010-08-19 08:00:14 EDT
Fedora doesn't distinguish between packages installed only to be built against and packages installed actually to be used.  You'd need a way to distinguish between 'install this package to compile against but I promise I will never actually run any of the contents because I know there are dependencies missing and things will break if I try that' and 'install this package actually to be used including all its runtime requirements'.

If you know what you are doing, manage the dependencies yourself with --nodeps.

Note You need to log in before you can comment on or make changes to this bug.