This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 625331 - RFE -- allow customization of the site name for Publican websites
RFE -- allow customization of the site name for Publican websites
Status: CLOSED ERRATA
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-19 01:30 EDT by Ruediger Landmann
Modified: 2010-11-23 23:17 EST (History)
4 users (show)

See Also:
Fixed In Version: publican-2.2-0.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-10 19:26:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ruediger Landmann 2010-08-19 01:30:39 EDT
Description of problem:
The site name that appears in the index.html file in the root of a Publican-generated website contains <title>Documentation</title> in its head, and <h1>Documentation</h1> in its body. 

These values are picked up by search engines indexing the site, so it would be helpful if this value could be customized to include an organization or product name; for example "Red Hat Documentation". 

Customizing this value would also help people building websites with a default language other than English, since they could choose a title and h1 that reflect the default language.

Maybe this could be set with a parameter in the homepage.cfg file and an option in the create_site action?

Version-Release number of selected component (if applicable):
2.1

How reproducible:
100%

Steps to Reproduce:
1. create a publican website with publican create_site
2. open the index.html file in an editor. 
  
Actual results:
<title> and <h1> say "Documentation"

Expected results:
<title> and <h1> are configurable.

Additional info:
The workaround is to manually edit the index.html file, but you need to re-do this every time that the site is refreshed, because index.html gets overwritten.
Comment 1 Jeff Fearn 2010-10-03 22:34:10 EDT
Added "title" parameter to site configuration file.

Fixed in Build: 2.1-%{?dist}.t120

Note You need to log in before you can comment on or make changes to this bug.