Bug 625334 - libvird does not dump core on SEGV
libvird does not dump core on SEGV
Status: CLOSED DUPLICATE of bug 623166
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
Depends On:
Blocks: 581275 622498
  Show dependency treegraph
 
Reported: 2010-08-19 01:51 EDT by Dan Kenigsberg
Modified: 2010-11-08 17:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-08 17:17:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Kenigsberg 2010-08-19 01:51:42 EDT
Description of problem:
If signaled right on startup, everything's fine:

# libvirtd & kill -SEGV $!
[1] 11144
[1]+  Segmentation fault      (core dumped) libvirtd

But if given enough time, libvirt no longer dumps the core:

# libvirtd & sleep 10; kill -SEGV $!
[1] 11567
[1]+  Segmentation fault      libvirtd


Version-Release number of selected component (if applicable):
libvirt-0.8.1-23.el6.x86_64

How reproducible:
always
Comment 1 Dave Allan 2010-11-08 17:17:54 EST
This looks like a dup of 623166 to me; if that's not right, please say so and reopen.

*** This bug has been marked as a duplicate of bug 623166 ***

Note You need to log in before you can comment on or make changes to this bug.