Bug 62535 - dietlibc segfaults on older RedHat version
dietlibc segfaults on older RedHat version
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: dietlibc (Show other bugs)
1.0
i686 Linux
low Severity low
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-04-02 03:11 EST by vvs
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-08 07:09:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vvs 2002-04-02 03:11:25 EST
Description of Problem:

When dietlibc from Rawhide is compiled on RedHat 7.2 and then nash is linked
against it, nash segfaults

Version-Release number of selected component (if applicable):

dietlibc-0.15-2
mkinitrd-3.3.6-1
gcc-2.96-109
binutils-2.11.93.0.2-10
glibc-2.2.4-13
kernel-headers-2.4.7-10
kernel-2.4.7-10

How Reproducible:

Seems always

Steps to Reproduce:
1. rebuild and install dietlibc from src rpm
2. rebuild and install mkinitrd from src rpm
3. run nash

Actual Results:

segfault

Expected Results:

command prompt

Additional Information:
	
I'm not sure what exactly going on here. If I'd use latest kernel and glibc from
rawhide then there wont be no segfault and it works as expected. I suppose diet
shouldn't depend on glibc? Is it the kernel? Apparently gcc and binutils are not
involved, because I have the same versions on both installations.
Comment 1 vvs 2002-04-02 06:52:12 EST
I've just upgraded to latest errata kernel-2.4.9-31 and glibc-2.2.4-19.3 for
RedHat 7.2 and it didn't help. Also, any program, even hello world will crash
when compiled and linked with dietlibc in this configuration.
Comment 2 vvs 2002-04-03 00:20:31 EST
The reason for broken executables is that ld can not find entry symbol _start
and it defaults to 08040808. Yesterday I downgraded binutils and gcc on computer
with glibc 2.2.5 to RedHat 7.2 stock versions and rebuilt dietlibc, but it still
works there. Same thing didn't help on other computer (with glibc 2.2.4), really
weird.
Comment 3 Jeremy Katz 2002-04-04 17:35:38 EST
Works for me on my machine running 7.2

1070 katzj@orthanc:~> rpm -q glibc gcc binutils
glibc-2.2.4-19.3
gcc-2.96-98
binutils-2.11.90.0.8-12
1071 katzj@orthanc:~> diet gcc -o test test.c
1072 katzj@orthanc:~> ./test 
hello world
Comment 4 vvs 2002-04-08 07:08:58 EDT
I'd like to agree with you and forget the whole thing, but unfortunately the
facts will not. Please, do not disregard this message! I know you're busy, but I
spent much time to test it and I can reproduce this bug on every single computer
I've tried.

_Don't_ install dietlibc from binary rpm, if it was built on "good"
configuration (whatever it is) it will work on any other one. To reproduce this
bug you must install stock Red Hat 7.2 from scratch, rebuild dietlibc from
_source_ rpm on _that_same_ computer and compile hello world with this diet. I'm
afraid that may be something bad is behind this bug (e.g. some binary
incompatibility between two Red Hat versions).
Comment 5 Erik Troan 2002-05-26 17:49:24 EDT
There probably is something a bit weird going on in dietlibc's static binaries,
but I'm not particularly interested in fixing it. We didn't ship (and don't
support) dietlibc on 7.2, so it's not that important to us.

I do agree that the behaviour is very disconcerting.

Note You need to log in before you can comment on or make changes to this bug.